Anzeige:
Ergebnis 1 bis 11 von 11

Thema: Kopfzeile – Seitenzahl, Kapiteltitel, section-Titel

  1. #1
    Registrierter Benutzer
    Registriert seit
    09.01.2012
    Beiträge
    34

    Kopfzeile – Seitenzahl, Kapiteltitel, section-Titel

    Guten Tag,
    Ich habe ein Buch in LaTeX verfasst und habe nun vom Verlag noch einige Vorschriften bekommen, wie die Seite genau auszusehen hat, was mir etwas Probleme bereitet.

    - Seitenzahl jeweils oben außen stehen
    - Kapitel- resp. Unterkapiteltitel jeweils oben mittig auf den geraden resp. ungeraden Seiten.

    Wenn ich das richtig verstanden habe, sollte dies einfach durch \pagestyle{myheadings} möglich sein, aber in meinem Dokument ändert sich dadurch gar nichts.

    Könnte mir jemand helfen?
    Herzlichen Dank

  2. #2
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.831
    AFAIK schaltet der myheadings-Seitenstil lebendige Kolumnentitel ab, d.h. Du müsstest dann entsprechend per \markright/\markboth manuelle Kolumnentitel erzeugen.
    Besser wäre \pagestyle{headings}, damit sind lebendige Kolumnentitel zumindest vorgesehen, allerdings werden diese im zweiseitigen Satz meist innen/außen gesetzt, nicht mittig, AFAIR. Das hängt aber auch von der verwendeten Klasse ab.
    Und dann gibt es noch Pakete wie scrlayer-scrpage, womit Du Dir Deine eigenen Seitenstile zurechtbasteln kannst.
    BTW: bei Buch- und Reportklassen werden bei Kapitelstartseiten meist andere Seitenstile wie plain oder empty verwendet (über der Kapitelüberschrift den vorherigen Abschnitt angeben zu wollen wäre IMHO auch recht sinnfrei).

    Wenn das nicht hilft, erstelle bitte ein Minimalbeispiel, das Dein Problem auch demonstriert.

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

  3. #3
    Registrierter Benutzer
    Registriert seit
    09.01.2012
    Beiträge
    34
    Danke erstmal. Entschuldige die unvollständigen Angaben. Ich verwende die Dokumentklasse scrbook und TeXShop 4.64.
    Ich habe es jetzt probiert. Du hast recht, myheadings gibt mir keine Kolumnentitel, bei headings werden sie aber aussen gesetzt. Die Seitenzahl bleibt aber bei beiden unten.
    Die Kolumnentitel sollten also mittig gesetzt werden, die Seitenzahl oben außen.

    Ich habe jetzt gerade das gefunden: https://esc-now.de/_/latex-individue...eilen/?lang=de
    Und habe das entsprechend auf mein Dokument angewendet. So sollte es funktionieren, nicht wahr? Oder muss ich mich auf unangenehme Überraschungen gefasst machen?



    %!TEX encoding = UTF-8 Unicode
    %A. PRÄAMBEL
    %************************************************* **************************************************

    \documentclass[10pt,a4paper, DIV=calc,version=first, headings=normal, twoside, bibtotoc]{scrbook}

    \usepackage[ngerman]{babel}

    \setkomafont{sectioning}{\normalfont}

    \setfootnoterule{0pt}

    \usepackage[textwidth=103 mm, textheight=163 mm,includeheadfoot]{geometry}
    \usepackage{blindtext}
    \usepackage{scrpage2}

    %148 x 245 A4 Format, 103 x 163 kleines Buchformat

    \begin{document}

    \pagenumbering{Roman}

    \chapter{Lorem}
    \pagestyle{scrheadings}
    \clearscrheadfoot
    %\ihead{}
    \chead{\headmark}
    \ohead{\pagemark}
    %\ifoot{Fußzeile innen}
    %\cfoot{Fußzeile Mitte}
    %\ofoot{Fußzeile außen}


    \pagenumbering{arabic}
    \section{Ipsum}
    \Blindtext
    \section{Dolor}
    \blindtext
    \section{Sit}
    \Blindtext
    \section{Amet}
    \Blindtext
    \section{Consetetur}
    \Blindtext


    \end{document}

  4. #4
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.831
    Zitat Zitat von kurunta Beitrag anzeigen
    Ich habe jetzt gerade das gefunden: https://esc-now.de/_/latex-individue...eilen/?lang=de
    Und habe das entsprechend auf mein Dokument angewendet. So sollte es funktionieren, nicht wahr? Oder muss ich mich auf unangenehme Überraschungen gefasst machen?
    scrpage2 ist veraltet. Für einige Zeit gab es scrpage2 noch parallel zum Nachfolger scrlayer-scrpage, die aktuelle Version des KOMA-Script-Bündels kommt inzwischen ohne scrpage2.

    BTW: klick unter dem von Dir angegebenen Link mal auf `überarbeitete Variante', da wird scrlayer-scrpage verwendet;-)

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

  5. #5
    Registrierter Benutzer
    Registriert seit
    09.01.2012
    Beiträge
    34
    Super. Danke. Tja, genau lesen wäre was...
    Jetzt funktioniert es. Kann ich noch irgendwie bestimmen, dass nicht der Titel inklusive Zahl (z.B. "1 Einleitung") sondern nur der Titel ("Einleitung") steht?

  6. #6
    Registrierter Benutzer
    Registriert seit
    09.01.2012
    Beiträge
    34
    Könntest du noch drüber schauen, ob die Lösungen, die ich für die Vorgaben des Verlages gefunden habe, so up-to-date sind und funktionieren sollten? Ich wäre sehr dankbar!

    Die Überschriften sollten nicht fett gedruckt werden.
    \setkomafont{sectioning}{\bfseries} zu \setkomafont{sectioning}{\normalfont} ändern.

    Der letzte Punkt hinter den Ziffer zu den Kapitel muss entfernt werden.
    Dieses Problem hat sich erledigt. Ich weiß aber nicht wieso.

    Die Fußnotentrennlinien sollten entfernt werden.
    \setfootnoterule{0pt}

    Wenn Sie einen Kolumnentitel verwenden, soll die Seitenzahl auch oben, außen platziert werden.
    \usepackage{scrlayer-scrpage}
    ……

    \pagestyle{scrheadings}
    \clearpairofpagestyles
    %\ihead{}
    \chead{\headmark}
    \ohead{\pagemark}
    %\ifoot{Fußzeile innen}
    %\cfoot{Fußzeile Mitte}
    %\ofoot{Fußzeile außen}

  7. #7
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.831
    Zitat Zitat von kurunta Beitrag anzeigen
    Die Überschriften sollten nicht fett gedruckt werden.
    \setkomafont{sectioning}{\bfseries} zu \setkomafont{sectioning}{\normalfont} ändern.
    Wenn die Überschriften nur ``nicht fett'' sein und serifenlos bleiben sollen, dann wäre
    Code:
    \addtokomafont{sectioning}{\mdseries}
    passender.
    Zitat Zitat von kurunta Beitrag anzeigen
    Der letzte Punkt hinter den Ziffer zu den Kapitel muss entfernt werden.
    Dieses Problem hat sich erledigt. Ich weiß aber nicht wieso.
    Bei rein numerischen Gliederungsnummerierungen wird auch kein abschließender Punkt gesetzt. Wenn hier andere Nummerierungsarten ins Spiel kommen (wie z. B. A, B.. im Anhang), dann werden alle Gliederungsnummerierungen mit abschließendem Punkt versehen, siehe dazu auch die Erklärung zu `numbers' im scrguide.
    Wenn Du das abschalten willst, ergänze numbers=noendperiod zu den Klassenoptionen.
    Zitat Zitat von kurunta Beitrag anzeigen
    Wenn Sie einen Kolumnentitel verwenden, soll die Seitenzahl auch oben, außen platziert werden.
    \usepackage{scrlayer-scrpage}
    ……

    \pagestyle{scrheadings}
    \clearpairofpagestyles
    %\ihead{}
    \chead{\headmark}
    \ohead{\pagemark}
    %\ifoot{Fußzeile innen}
    %\cfoot{Fußzeile Mitte}
    %\ofoot{Fußzeile außen}
    Ich würde das komplett in der Präambel lassen.
    Zitat Zitat von kurunta Beitrag anzeigen
    Kann ich noch irgendwie bestimmen, dass nicht der Titel inklusive Zahl (z.B. "1 Einleitung") sondern nur der Titel ("Einleitung") steht?
    Du meinst nur in den Kopfzeilen? Sicher, das geht mit
    Code:
    \renewcommand*\chaptermarkformat{}
    \renewcommand*\sectionmarkformat{}
    BTW: bei Deinem zuvor gepostetem Code setzt Du version=first, hat das einen speziellen Grund? Die Warnung bezüglich bibtotoc sagt Dr eigentlich, was Du stattdessen verwenden solltest.;-)

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

  8. #8
    Registrierter Benutzer
    Registriert seit
    09.01.2012
    Beiträge
    34
    Zitat Zitat von rais Beitrag anzeigen
    Wenn die Überschriften nur ``nicht fett'' sein und serifenlos bleiben sollen, dann wäre
    Code:
    \addtokomafont{sectioning}{\mdseries}
    passender.
    Ich verwende im Originaldokument den Brill-Font (https://brill.com/page/290?language=en), der nicht serifenlos ist. Müsste ich also

    Code:
    \setkomafont{sectioning}{\rmfamily}
    verwenden? Das Ergebnis ist aber das Gleiche wie bei
    Code:
    \setkomafont{sectioning}{\normalfont}



    Zitat Zitat von rais Beitrag anzeigen
    Du meinst nur in den Kopfzeilen? Sicher, das geht mit
    Code:
    \renewcommand*\chaptermarkformat{}
    \renewcommand*\sectionmarkformat{}
    Das hat super funktioniert. Vielen Dank. Wenn ich jetzt die Kopfzeile noch normal (nicht kursiv) haben will, darf ich das dann so lösen?
    Code:
    \renewcommand*\chaptermarkformat{\upshape{}}
    \renewcommand*\sectionmarkformat{\upshape{}}
    Scheint auf jeden Fall zu funktionieren.

    Zitat Zitat von rais Beitrag anzeigen
    BTW: bei Deinem zuvor gepostetem Code setzt Du version=first, hat das einen speziellen Grund? Die Warnung bezüglich bibtotoc sagt Dr eigentlich, was Du stattdessen verwenden solltest.;-)

    VG
    Ganz ehrlich: Ich habe die meisten Teile der documentclass unverändert gelassen seit ich angefangen habe. Und ich habe mir die Fehlermeldungen auch nie so ganz im Detail angesehen, wenn etwas Sinnvolles ausgegeben wurde. Aber ich sehe, dass beide Befehle (bibtotoc und version=first) ins Leere laufen und lösche sie weg.

  9. #9
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.831
    Zitat Zitat von kurunta Beitrag anzeigen
    Ich verwende im Originaldokument den Brill-Font (https://brill.com/page/290?language=en), der nicht serifenlos ist. Müsste ich also

    Code:
    \setkomafont{sectioning}{\rmfamily}
    verwenden? Das Ergebnis ist aber das Gleiche wie bei
    Code:
    \setkomafont{sectioning}{\normalfont}
    In dem Fall würde ich bei der \normalfont-Variante bleiben (\normalfont setzt \familydefault, \seriesdefault und \shapedefault, das entspricht -- so da keiner dran gedreht hat -- in etwa \rmfamily\mdseries\upshape).
    Zitat Zitat von kurunta Beitrag anzeigen
    Wenn ich jetzt die Kopfzeile noch normal (nicht kursiv) haben will, darf ich das dann so lösen?
    Code:
    \renewcommand*\chaptermarkformat{\upshape{}}
    \renewcommand*\sectionmarkformat{\upshape{}}
    Scheint auf jeden Fall zu funktionieren.
    Kannst Du so machen. Ich würde die beiden \*markformat-Anweisungen leer definieren und stattdessen irgendwo nach Laden des scrlayer-scrpage-Pakets
    Code:
    \setkomafont{pageheadfoot}{\normalcolor}
    setzen, da kam Dein \slshape (schräggestellt, nicht kursiv) her.

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

  10. #10
    Registrierter Benutzer
    Registriert seit
    09.01.2012
    Beiträge
    34
    Super! Vielen, vielen Dank.
    Ich hoffe, der Verlag ist jetzt glücklich mit den Änderungen.

  11. #11
    Registrierter Benutzer
    Registriert seit
    03.06.2010
    Ort
    Bischoffen
    Beiträge
    129
    Hallo, ich schreibe auch Bücher. Benutze \usepackage{geometry}. Kapitel-Übeschriften mit \usepackage[Glenn]{fncychap} Option [glenn] ist eine von 5 oder 6 Alternativen.
    \usepackage{microtype}
    % für ransausgleich
    \geometry{
    paperwidth=103mm,
    paperheight=163mm,
    top=20mm,
    outer=20mm,
    inner=18mm}
    Geändert von Daniel (06-06-2021 um 19:39 Uhr)

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •