Anzeige:
Ergebnis 1 bis 5 von 5

Thema: Option "show" und "hide" im cloze package

  1. #1
    Registrierter Benutzer
    Registriert seit
    24.05.2009
    Beiträge
    174

    Option "show" und "hide" im cloze package

    Ich verstehe nicht, warum die Optionen "show" und "hide" nicht funktionieren (cloze package). Hier ein Minimalbeispiel:

    Code:
    \documentclass[12pt,paper=a4]{scrartcl}
    \usepackage[ngerman]{babel}
    \usepackage[]{cloze}
    %
    %
    \begin{document}
    %
    %
    \clozeset{hide}
    %
    %
    Jemand musste Josef K. \cloze{verleumdet} haben, denn \cloze[show]{ohne} dass er etwas Böses getan hätte, wurde er eines Morgens verhaftet.
    \end{document}
    Ich möchte, dass nur das Wort "ohne" angezeigt wird!?

  2. #2
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.810
    die Optionen funktinieren schon, nur, sie wirken sich auf den kompletten Absatz aus...und die im Absatz letztgenannte Option `gewinnt'.
    Frag ggf. beim Paketautor nach, wie Du Dein Ziel mit seinem Paket erreichen kannst.

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

  3. #3
    Registrierter Benutzer
    Registriert seit
    24.05.2009
    Beiträge
    174
    Danke für deine Antwort! Ich muss mir das noch mal in Ruhe ansehen. Ganz steige ich da noch nicht durch. \cloze[show]{ohne} müsste doch eigentlich "gewinnen", oder?

  4. #4
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.810
    Wieso `müsste'? Wird `ohne' bei Dir denn nicht angezeigt?

    Code:
    \documentclass[12pt,paper=a4]{scrartcl}
    \usepackage[ngerman]{babel}
    \usepackage{cloze}
    \clozesetfont{\itshape}
    %
    \begin{document}
    %
    %
    \clozeset{hide}
    %
    % (1)
    Jemand musste Josef K. \cloze{verleumdet} haben, denn \cloze[show]{ohne} dass er etwas Böses getan hätte, wurde er eines Morgens verhaftet.
    
    % (2)
    Jemand musste Josef K. \cloze{verleumdet} haben,
    
    denn \cloze[show]{ohne} dass er etwas Böses getan hätte, wurde er eines Morgens verhaftet.
    
    % (3)
    Jemand musste Josef K. \cloze{verleumdet} haben, denn \cloze[show]{ohne} dass er etwas \cloze[hide]{Böses} getan hätte, wurde er eines Morgens verhaftet.
    
    \end{document}
    Bei (1) werden `verleumndet' und `ohne' angezeigt (`show' gewinnt')

    Bei (2) wird `verleumndet' nicht angezeigt (entsprechend dem zuvor gesetzten \clozeset{hide}, `ohne' wird hingegen angezeigt (entspricht fast dem, was Du erreichen willst, wäre da nicht der neue Absatz)

    Bei (3) wird weder `verleumndet' noch `ohne' angezeigt, weil die zuletzt aufgerufene Option `hide' (bei \cloze[hide]{Böses}) `gewinnt'.

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

  5. #5
    Registrierter Benutzer
    Registriert seit
    24.05.2009
    Beiträge
    174
    Zitat Zitat von rais Beitrag anzeigen
    die Optionen funktinieren schon, nur, sie wirken sich auf den kompletten Absatz aus...und die im Absatz letztgenannte Option `gewinnt'.
    Frag ggf. beim Paketautor nach, wie Du Dein Ziel mit seinem Paket erreichen kannst.
    Ah, danke für den Hinweis! Jetzt hab ich es verstanden. Die Option wirkt sich ja auf den kompletten Absatz aus ...

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •