Anzeige:
Ergebnis 1 bis 2 von 2

Thema: Bibliography-Probleme mit Sonderzeichen "°"

  1. #1
    Registrierter Benutzer
    Registriert seit
    15.04.2011
    Beiträge
    93

    Bibliography-Probleme mit Sonderzeichen "°"

    Guten Abend,

    ich bitte um Hilfe mit meinen Quellenangaben. Dazu folgt gleich ein kleines Minimalbeispiel, doch zuerst eine kurze Beschreibung der Siutation:
    1. Alle meine Dateien sind (sichergestellt) im UTF8-Format gespeichert. Dies gilt besonders für die Bib-Datei!
    2. In der Bib-Datei gibt es einen Eintrag, der ein Sonderzeichen "°" verwendet.
    3. Obwohl ich in dem Minimalbeispiel "\usepackage[utf8]{inputenc}" verwende, erhalte ich immer eine Fehlermeldung: ...Unicode char ...not set up for use with Latex.

    Fragen:
    1. Was kann ich tun, damit dieses Sonderzeichen "°" (sowie andere Umlaute ä,ö,ü oder ß akzeptiert werden)?
    2. In meiner Arbeit verwende ich auch das Paket "\usepackage[T1]{fontenc}". Sobald ich es in diesem Minimalbeispiel jedoch aktiviere, ist mein Dokument blank/weiß. Beißt sich dieses Paket mit irgendetwas in meinem Minibeispiel?

    Vielen Dank für die Hilfe.

    Code:
    \documentclass[a4paper, 12pt, listof=totoc, bibliography=totoc, index=totoc, headsepline, parskip=half, twoside, BCOR=12mm, parskip=false]{scrbook}
                                            
    \usepackage[ngerman]{babel}    
    \usepackage[utf8]{inputenc}
    %\usepackage[T1]{fontenc} <-- Frage 2)    
    \usepackage{natbib}
    \usepackage[dvips,pdfpagelabels]{hyperref}
    \hypersetup{
            pdftitle={Diplomarbeit Vorname Nachname},    
            pdfauthor={Vorname Nachname},
            pdfcreator={LaTeX2e},
            pdfborder=0 0 0,
            breaklinks=true,
            bookmarksopen=true,
            bookmarksnumbered=true,
            linkcolor=blue,
            urlcolor=blue,
            citecolor=blue,
            colorlinks=false}
    
    \begin{document}
     \cite{Autor1}
     \renewcommand{\bibfont}{\normalfont\footnotesize} % Aendert Schriftgröße in Literaturverzeichnis
     \bibliographystyle{plainnat}
     \bibliography{Datenbank_v3}
    \end{document}
    
    Bib-Datei: Datenbank_v3.bib
    ...
    ...
    @proceedings{Autor1,
        title = "{Text Text.... 180° .... Text ä ö ü}",
        author = {Vorname Nachname},
        ...
    }

  2. #2
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.768
    zu 1) Sonderzeichen wie ° müssen erst deklariert werden, sonst weiß LaTeX nicht, was Du damit wirklich willst. Das hat dann auch nicht direkt mit der .bib zu tun.
    Bei den Umlauten sollte das bereits verwendete babel-Paket mit ngerman-Option und übereinstimmende Eingangskodierung (reale Kodierung und Angabe bei inputenc) genügen.

    zu 2) Evtl. ist die verwendete Schrft (cm) nicht komplett installiert, evtl. hakt es auch an der an hyperref übergebene dvips-Option. Womit kompilierst Du denn?

    Code:
    \documentclass{scrbook}
    \usepackage[ngerman]{babel}    
    \usepackage[utf8]{inputenc}
    \DeclareUnicodeCharacter{00B0}{\ensuremath{^\circ}}%<--die Nummer (im ersten Argument) erfährst Du aus der Fehlermeldung ohne entsprechenden \DeclareUnicodeCharacter. Im zweiten Argument steht dann das, was LaTeX fürs Sonderzeichen (hier 00B0 oder °) einsetzen soll
    \usepackage[T1]{fontenc}% <-- Frage 2)    
    
    \begin{document}
    Text.... 180° .... Text ä ö ü
    \end{document}
    BTW: erst setzt Du parskip=half, kurz darauf parskip=false, was denn nu?
    Seit TL18 kannst Du \usepackage[utf8]{inputenc} auch weglassen.
    Treiberangaben wie dvips/pdftex für hyperref (auch graphicx und co) würde ich weglassen, die Pakete finden seit einigen Jahren recht zuverlässig selbst raus, womit kompiliert wird.
    BibTeX ist nicht gerade berühmt für seine utf8-Unterstützung, da schon eher biblatex+biber.

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •