Anzeige:
Ergebnis 1 bis 2 von 2

Thema: Latex CSV Tabellen zwei Probleme! Komma und \cline

  1. #1
    Registrierter Benutzer
    Registriert seit
    06.08.2019
    Beiträge
    3

    Latex CSV Tabellen zwei Probleme! Komma und \cline

    Hallo alle zusammen!

    Leider komme ich nicht mehr weiter und hoffe sehr auf eure Unterstützung!

    In der folgenden Tabelle habe ich zwei Probleme:


    Code:
    \begin{footnotesize}
    \begin{longtable}[H]{L{5cm}|p{1.8cm}|p{1.8cm}|p{1.8cm}|p{1.8cm}|p{1.8cm}}%
    \rowcolor{Business4}\bfseries \textcolor{white}{Energetisch} &  \multicolumn{2}{|c|}{\bfseries \textcolor{white}{Energiebedarf \newline (-verbrauch)}} & \multicolumn{3}{|c}{\bfseries \textcolor{white}{Einsparung}}
    \\\cline{1-6}
    &(kWh/a)& (kWh/m\textsuperscript{2}) & (kWh/a)&(\%/a) &(kWh/30a) 
    \\\cline{1-6}
    \csvreader[head to column names]{CSV/Massnahmenergebnisse.csv}{}%
    {\\\energetisch & \energiebedarfa & \energiebedarfam	& \einsparungkwha	& \einsparungpa	& \einsparungkwhax}%
    \\
    
    \rowcolor{Business4}\bfseries \textcolor{white}{Wirtschaftlichkeit und Umwelt} & \bfseries \textcolor{white}{Investition} & \bfseries \textcolor{white}{Einsparung} & \bfseries \textcolor{white}{Stat. Amortisation} &  \bfseries \textcolor{white}{CO\textsubscript{2}}& \bfseries \textcolor{white}{CO\textsubscript{2}-Einsparung} 
    \\\cline{1-6}
    &(\euro)&  (\euro/a) & (a) & (t/a) & (\%) 
    \\\cline{1-6}
    \csvreader[head to column names]{CSV/Massnahmenergebnisse.csv}{}%
    {\\\wirtschaftlich & \investition & \einsparungazwei	& \amortisation	& \cozwei & \einsparungco }%
    \\
    
    \caption{Maßnahmenergebnisse}
    \end{longtable}
    \end{footnotesize}
    Und so sieht die Ausgabe aus!
    1.PNG


    Problem Nr.1:
    Nachdem ich die Zeilen mit \\\cline und den Formeln hinterlegt habe, erscheint immer eine leere Zeile nach den Einheiten! Dabei habe ich nirgends eingestellt, dass leere Zeilen erstellt werden sollen... Keine Ahnung woher diese plötzich auftauchen! und dies ist auch bei anderen Tabellen so, die denselben Aufbau haben!


    Problem Nr.2:
    Die CSV Datei bearbeite ich mit OpenOffice. Mir ist bewusst, dass wenn ich in der CSV Tabelle Dezimalzahlen verwenden will die Einstellung des Textimports auf Semikolon stellen muss, da sonst die Kommas als Trenner verwendet werden.
    Nur leider funktioniert bei mir dann der Import nicht mehr.
    So ist die momentane "falsche" Einstellung:
    2.PNG
    Sobald ich auf Semikolon stelle sieht die Einstellung so aus:
    3.PNG

    und folgende Fehlermeldung taucht dann auf: Argument of \language@active@arg" has an extra }.

    Könnte mir bitte jemand weiterhelfen?


    Grüße

    EEKaur

  2. #2
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.752
    Zu Deinem ersten Problem kann ich ohne Minimalbeispiel Deinerseits wenig sagen.

    Zu Deinem zweiten Problem: Beim Import musst Du schon das Trennzeichen angeben, das in der .csv auch verwendet wurde.
    Dann solltest Du beim Export in der Lage sein, das Trennzeichen auf Semikolon zu verändern.
    Dazu musst Du dann natürlich auch dem \csvreader per "separator=semicolon" - Option mitteilen, daß sich das Trennzeichen geändert hat. (So es denn der Befehl aus csvsimple ist)

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •