Anzeige:
Ergebnis 1 bis 7 von 7

Thema: Abstand zw. Tabelle und Überschriften

  1. #1
    Registrierter Benutzer
    Registriert seit
    03.08.2011
    Beiträge
    18

    Abstand zw. Tabelle und Überschriften

    Hallo zusammen,
    ich habe ein Dokument in lyx erstellt, indem einige Tabellen sind.
    Jetzt wollte ich den Abstand zwischen einer Tabellenüberschrift und der Tabelle mit vertikalem Abstand regeln. Wenn ich mir aber dann die pdf-Version anschaue ist bei zwei Tabellen der Abstand zwischen der Überschrift und der Tabelle geringer. Weiß jemand woran das liegen könnte?
    Danke schonmal und VG

  2. #2
    Registrierter Benutzer
    Registriert seit
    09.12.2005
    Beiträge
    1.311
    Zwischen Tabellenüberschrift und Tabelle von Hand einen Abstand einzufügen ist keine gute Idee, weil es viel zu fehleranfällig ist und außerdem der Trennung von Form und Inhalt widerspricht. Besser ist, generell die Formatierung für Tabellenüberschriften statt Tabellenunterschriften zu aktivieren. Bei den KOMA-Script-Klassen geht das beispielsweise mit Klassenoption `caption=tableheading`. Im Zweifelfall kann man das auch per `\KOMAoptions{caption=tableheading}` noch in der Dokumentpräambel einschalten. Näheres zu \KOMAoptions und Option caption ist der KOMA-Script-Anleitung oder dem KOMA-Script-Buch zu entnehmen.

    Verwendet man keine KOMA-Script-Klasse, so ist vergleichbares auch mit dem Paket caption möglich. Die dortige Option ist der Anleitung des Pakets zu entnehmen (ich müsste die auch erst nachschlagen).

  3. #3
    Registrierter Benutzer Avatar von localghost
    Registriert seit
    01.11.2006
    Ort
    Braunschweig
    Beiträge
    3.413

    Genauere Angaben

    Fertige ein ordentliches Minimalbeispiel an.


    Thorsten
    TeX und LaTeX, Fragen und Antworten – TeXwelt

    ¹ Es tut mir Leid. Meine Antworten sind begrenzt. Sie müssen die richtigen Fragen stellen.
    ² System: openSUSE 13.1 (Linux 3.11.10), TeX Live 2013, TeXworks 0.5 (r1351)

  4. #4
    Registrierter Benutzer
    Registriert seit
    03.08.2011
    Beiträge
    18
    @ Klops, danke schomal
    Wenn ich jetzt --> Dokumentenklase --> Klassenoptionen deinen Befehl: caption=tableheading eingebe, wird der Abstand zwischen Überschrift und Tabelle geringer. Allerdings ist bei einer! Tabelle der Abstand noch immer größer als bei den anderen. Dieser Abstand war zuvor auch größer als bei den anderen Tabellen.
    Wenn ich jetzt unter dem Latex-Vorspann den Befehl \KOMAoptions{caption=tableheading} eingebe, kommt bei der pdf-Vorschau dieser Fehler:

    ! Package scrkbase Error: unknown KOMA option `caption'.

    Meintest du das so oder habe ich da was falsch gemacht?

  5. #5
    Registrierter Benutzer
    Registriert seit
    06.03.2010
    Ort
    St. Petersburg, Russland
    Beiträge
    2.468
    Wenn es als Klassenoption funktioniert, brauchst du ja nicht zusätzlich noch \KOMAoptions zu bemühen. Warum der Fehler kommt, ist mir allerdings rätselhaft.

    Hast du bei dieser einen Tabelle irgendwas anders gemacht?
    Versuch mal ein Minimalbeispiel zu erstellen: du speicherst dein Dokument unter anderem Namen, entfernst so viel, wie du kannst, aber so, dass das Problem noch sichtbar ist (also muss mindestens diese eine Tabelle und noch eine andere Tabelle drin bleiben, aber evtl. kannst du deren Inhalt kürzen), und dann exportierst du dein Dokument über das Menü Datei - exportieren (oder so ähnlich, habe selbst kein Lyx mehr) als .tex-Dokument. Dieses Dokument kannst du dann mit Notepad oder so öffnen, alles markieren, kopieren und den gesamten Inhalt hier ins Forum posten, am besten zwischen [ CODE]... [ /CODE]-Tags (#-Symbol in der Formatierungsleiste.

  6. #6
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    4.045
    Zitat Zitat von rstuby Beitrag anzeigen
    Wenn es als Klassenoption funktioniert, brauchst du ja nicht zusätzlich noch \KOMAoptions zu bemühen. Warum der Fehler kommt, ist mir allerdings rätselhaft.
    Nun, der Fehler deutet darauf hin, dass es auch als Klassenoption nicht funktioniert. Und tatsächlich erhält man dort:

    Code:
    LaTeX Warning: Unused global option(s):
        [caption=tableheading].

    Die Option heißt nämlich "captions=tableheading" (mit s).

  7. #7
    Registrierter Benutzer
    Registriert seit
    03.08.2011
    Beiträge
    18
    ich habs jetzt durch vertikale Abstände bei den Tabellen gemacht, bei denen die Abstände gleich waren um somit auf den Abstand bei der Tabelle zu kommen, die nach wie vor einen größeren Abstand hat. Die Tabellen sind absolut identisch aufgebaut. Habs auch nochmal neu versucht, jedoch ohne Erfolg.
    Die Lösung ist zwar nicht im Sinne des Erfinders, aber gut.
    Auf alle Fälle ein großes Danke für deine (schnelle) Hilfe!

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •