Anzeige:
Ergebnis 1 bis 7 von 7

Thema: Eckige Klammern in LaTeX

  1. #1
    Registrierter Benutzer
    Registriert seit
    30.08.2008
    Beiträge
    18

    Eckige Klammern in LaTeX

    Hallo!

    Ich habe in der comprehensive LaTeX symbol list keine Entsprechung für normale eckige Klammern [] gefunden.

    Ich brauche Sie aber außerhalb einer verbatim Umgebung, wenn es geht. Wie mache ich das?

    Danke für Hinweise!

  2. #2
    Registrierter Benutzer Avatar von The EYE
    Registriert seit
    15.12.2008
    Ort
    Hameln
    Beiträge
    332
    Hey!

    Hier zwei Möglichkeiten (bzw. eine, wenn du kein verbatim willst). Wieso eigentlich nicht?
    Wenn du das hyperref Paket benutzt wird bei der zweiten Lösung das [ fälschlicher Weise verlinkt.

    Code:
    \documentclass{article}
    \usepackage[T1]{fontenc}
    \usepackage[latin1]{inputenc}
    
    \usepackage{url}
    
    \begin{document}
    
    Mit verbatim \verb|[|
    
    Url-Paket "missbrauchen" \url{[}
    
    \end{document}
    Gruß Max
    ¹: Erstelle bitte ein richtiges Minimalbeispiel
    ²: Ich nutze Ubuntu 14.04, TeX Live 2014 & Kile 2.1.3

  3. #3
    Registrierter Benutzer
    Registriert seit
    10.07.2010
    Ort
    Offenhausen
    Beiträge
    654
    Code:
    \listfiles
    \documentclass{scrartcl}
    \usepackage[T1]{fontenc}
    \usepackage[utf8]{inputenc}
    
    \begin{document}
    [Wo ist das Problem] ????
    \end{document}
    Siehe Anhang.
    Gruß, Sepp-

  4. #4
    Registrierter Benutzer Avatar von The EYE
    Registriert seit
    15.12.2008
    Ort
    Hameln
    Beiträge
    332
    Code:
    \ensuremath{[}
    ginge auch noch

    Gruß Max
    ¹: Erstelle bitte ein richtiges Minimalbeispiel
    ²: Ich nutze Ubuntu 14.04, TeX Live 2014 & Kile 2.1.3

  5. #5
    Registrierter Benutzer
    Registriert seit
    30.08.2008
    Beiträge
    18
    Vielen vielen Dank!!


    Ich hatte ehrlich gesagt einfach vorausgesetzt es wäre ein Problem ... *schäm*

    Nachdem ich es jetzt probiert habe, ist es aber tatsächlich eins. LaTeX erstellt an die 2000 pdf Seiten und hört dann mit einer Fehlermeldung auf zu kompilieren. Es liegt an \usepackage{times}, wenn ich das rausnehme, kann ich die eckigen Klammern ganz normal verwenden.

    Code:
    \documentclass{beamer}
    \usepackage[ngerman]{babel}
    \usepackage{times}
    \usepackage[latin1]{inputenc}
    \usepackage[T1]{fontenc}
    \usepackage{hyperref}
    \mode
    {
    \usetheme{lankton-keynote}  
    \setbeamercovered{transparent}
    }
    %%
    \begin{document}
    \begin{frame}{URI}{Syntax -- host}
    \begin{itemize}
    \item IPv6 in [] \pause [2001:db8::7] \pause
    \end{itemize}
    \end{frame}
    \end{document}
    Warum verbatim nicht funktioniert, muss ich noch ergründen.

    Aber \ensuremath{[]} funktioniert wunderbar.

    Vielen Dank, Max und Sepp!

  6. #6
    Registrierter Benutzer Avatar von Donalduck
    Registriert seit
    08.05.2007
    Ort
    Augsburg
    Beiträge
    754
    um verbatim in beamer benutzen zu können, musst du dem frame die option [fragile] übergeben.

  7. #7
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    4.043
    Code:
    LaTeX erstellt an die 2000 pdf Seiten und hört dann mit einer Fehlermeldung auf zu kompilieren. Es liegt an \usepackage{times}, wenn ich das rausnehme, kann ich die eckigen Klammern ganz normal verwenden.
    Nun, ich bekomme die 2001 Seiten bei deinem Dokument auch ohne times (aber ohne Fehlermeldung, ich habe allerdings den \mode-Befehl rausgenommen). Es liegt an dem \pause-Befehl. \pause kann ein optionales Argument haben, das angibt, auf welcher Seite es weitergehen soll. \pause [2001 ...] führt daher dazu, dass Beamer brav 2000 Seiten erzeugt, damit es auf Seite 2001 weiter machen kann.

    Benutze \pause \relax .... oder \pause{} ....

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •