Anzeige:
Results 1 to 6 of 6

Thread: Einbinden von Vorlagen und MiKTeX 2.9

  1. #1
    Registrierter Benutzer
    Join Date
    04.08.2011
    Posts
    93

    Einbinden von Vorlagen und MiKTeX 2.9

    Nabend zusammen,

    ich versuche nun schon seid einer geraumen Zeit Vorlagen meiner Universität in MiKTeX einzubinden. Jedoch weiß ich nicht woran es scheitert. Ich habe die Vorlagen in den MiKTeX Ordner kopiert. Dabei habe ich Dateien in folgenden Unterordner:

    \MiKTeX 2.9\tex\latex\tud\

    abgelegt. Jedoch möchte mein MiKTeX diese Vorlagen nicht. Nun weiß ich nicht wo der Fehler ist, da ich das selber Verfahren schon bei der KOMA-Script titlepage Vorlage erfolgreich angewandt habe.

    Die Vorlagen sind unter:

    http://tu-dresden.de/service/cd/4_latex

    zu finden. Außerdem habe ich hier noch die Fehlermeldung:

    Code:
    MiKTeX Problem Report
    Message: Not a TDS-compliant root directory.
    Data: C:\Program Files\MiKTeX 2.9\tex\latex\tud
    Source: Programs\MiKTeX\MO\MFC\PropPageRoots.cpp
    Line: 367
    MiKTeX: 2.9
    OS: Microsoft Windows 7 Business Edition, 32-bit (build 7600)
    Invokers: explorer
    SystemAdmin: yes
    PowerUser: no
    Root0: C:\Users\Lars\AppData\Roaming\MiKTeX\2.9
    Root1: C:\Users\Lars\AppData\Local\MiKTeX\2.9
    Root2: C:\ProgramData\MiKTeX\2.9
    Root3: C:\Program Files\MiKTeX 2.9\tex\latex\titlepage
    Root4: C:\Program Files\MiKTeX 2.9
    UserInstall: C:\Users\Lars\AppData\Roaming\MiKTeX\2.9
    UserConfig: C:\Users\Lars\AppData\Roaming\MiKTeX\2.9
    UserData: C:\Users\Lars\AppData\Local\MiKTeX\2.9
    CommonInstall: C:\Program Files\MiKTeX 2.9
    CommonConfig: C:\ProgramData\MiKTeX\2.9
    CommonData: C:\ProgramData\MiKTeX\2.9
    Die immer auftaucht wenn ich die Vorlagen versuche einzubinden. So ich hoffe ihr könnt mir Helfen.

    Grüße, Letscho

  2. #2
    Registrierter Benutzer bobmalaria's Avatar
    Join Date
    28.11.2006
    Location
    Düsseldorf
    Posts
    4.174
    hi,

    hast du texhash ausgeführt?

    es ist übrigens nicht ideal wenn du die dateien in den miktex hauptordner kopierst. solltest du miktex zu einer neuen version updaten, dann kann es sein das du dieses manuell installierte bundle verlierst.

    besser ist es einen lokalen baum in miktex zu erstellen. dazu in den miktex settings auf "root" klicken und dort einen baum eintragen

    z.b. C:\irgend-ein-ordner\tex\latex\tud

    diese ordnersturktur kannst du selbst auf deinem rechner anlegen. miktex führt dann im anschluss automatisch ein texhash aus und die dateien sollten gefunden werden.

    gruss
    Mein Ball ist umgefallen

  3. #3
    Registrierter Benutzer
    Join Date
    19.05.2009
    Posts
    4.043
    Code:
    Message: Not a TDS-compliant root directory.
    Data: C:\Program Files\MiKTeX 2.9\tex\latex\tud
    Nun, wie schon von bobmalaria gesagt, ist es keine gute Idee, den Hauptbaum für lokale Dateien zu verwenden. Wenn du das dennoch tun willst, musst du die FNDB im Modus aktualisieren (und nicht den Ordner als Root anmelden).


    Allerdings wird sein Vorschlag "C:\irgend-ein-ordner\tex\latex\tud" als lokalen Root einzutragen zu dem gleichen Fehler wie oben führen. Denn weder "C:\irgend-ein-ordner\tex\latex\tud" noch "C:\Program Files\MiKTeX 2.9\tex\latex\tud" sind eine "Root", also eine Wurzel eines texmf-Verzeichnisses.

    Die Wurzeln sind "C:\Program Files\MiKTeX 2.9" und "C:\irgend-ein-ordner".

  4. #4
    Registrierter Benutzer
    Join Date
    04.08.2011
    Posts
    93
    Guten Morgen ihr beiden,

    viele Dank für die Tipps.

    Quote Originally Posted by bobmalaria View Post
    hast du texhash ausgeführt?
    bitte was ist ein texhash?

    Quote Originally Posted by u_fischer View Post
    Nun, wie schon von bobmalaria gesagt, ist es keine gute Idee, den Hauptbaum für lokale Dateien zu verwenden. Wenn du das dennoch tun willst, musst du die FNDB im Modus aktualisieren (und nicht den Ordner als Root anmelden).
    Nachdem ich den FNDB aktualisiert habe, funktioniert die Einbindung der Vorlagen, wenn ich sie unter:

    "C:\Program Files\MiKTeX 2.9\tex\latex\tud"

    abgelegt habe. Danke nochmals für die Hilfe.

    Grüße, Letscho

  5. #5
    Registrierter Benutzer bobmalaria's Avatar
    Join Date
    28.11.2006
    Location
    Düsseldorf
    Posts
    4.174
    hi,

    ulrike hast natuerlich recht. root ist c:\iregend-ein-ordner oder eben der hauptbaum c:\...\Miktex2.x\miktex\

    texhash, oder in miktex "FNDB refresh" erstellt sowas wie eine liste von dateien. so weiss miktex welche dateien in welchem ordner vorhanden sind. erstellt man einen neuen ordner weiss miktex also nicht automatisch von dessen existenz, uebersieht ihn sozusagen. man muss also diese liste aktualisieren. das genau macht texhash.

    man kann also eine eingabeaufforderung/dos-fenster oeffen und dort einfach

    texhash

    eingeben oder man geht ueber das start->programme->miktex->settings in die miktex einstellungen und klickt 1x auf refresh FNDB
    Mein Ball ist umgefallen

  6. #6
    Registrierter Benutzer
    Join Date
    19.05.2009
    Posts
    4.043
    man kann also eine eingabeaufforderung/dos-fenster oeffen und dort einfach

    texhash
    In diesem Fall texhash --admin. (oder initexmf --admin -u)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •