Anzeige:
Ergebnis 1 bis 5 von 5

Thema: ...schon wieder die Umlaute... suche automatisches Ersetzen

Hybrid-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    Registrierter Benutzer
    Registriert seit
    25.10.2011
    Beiträge
    9

    ...schon wieder die Umlaute... suche automatisches Ersetzen

    Hallo, Moin moin und guten Tach jesagt!

    Ein ganz alter Hund, den ich hier ausgraben muss. Es ist mir auch unangenehm dass ich das jetzt hier tatsächlich nochmal bringen muss...aber bei mir wollen die Umlaute nicht.

    Ich habe schon gestern den kompletten Nachmittag dran verbracht und raffe es nicht. Es will einfach nich so wie es soll.

    Es gibt wohl die Möglichkeit unter Mac OSX mit TexShop Umlaute im Dokument selber zu verwenden "Ä" usw und dann wandelt er es korrekt in der Ausgabe um und zeigt den richtigen Umlaut an - entsprechend hier wieder "Ä". Aber nix is.

    Folgendes habe ich versucht:
    - Vorlage für eine Masterarbeit heruntergeladen (siehe: blog.stefan-macke.com/2009/04/24/latex-vorlage-fuer-meine-masterarbeit-an-der-ohm-hochschule-nuernberg/)
    - dort steht in Packages.tex
    Code:
    \usepackages[applemac]{inputenc}
    \usepackages[T1]{fontenc}]
    Text mit Umlauten nimmt der jetzt so nicht.
    Also Kodierung ist bei TexShop eingestellt: UNICODE UTF-8

    ... wenn ich jetzt ein neues Dokument öffne, und einen Standardtext eingebe (auch mit den oben genannten usepackages) gehts einfach nicht. Auch die Variante
    Code:
     \usepackages[utf8x]{inputenc}
    weder noch die Variante
    Code:
    \usepackages[utf8]{inputenc}
    bringen Erfolg.

    Mir ist das ganze auch zu Undurchsichtig. Ich will erstmal von der Art gefummele Abstand nehmen. Hintergrund meines Lösungsvorschlages ist, dass ich vor Jahren mal meine Bachelorarbeit geschrieben hatte, das gleiche Problem hatte und dann iiiiirgendwo im Netz die Lösung gefunden hatte, dass wenn ich in TexShop "ö" "ä" "ü" eingebe kommt " \"a" .. usw..
    Wo finde ich diese Anweisung??? Könnt ihr mir sagen wie ich diese Einstellung wiederfinde? Das ist der für mich einfachste Weg, so frisst das wenigstens TexShop meine Zeilen.


    Vielen vielen Dank im Voraus an alle fleißigen Helfer!

  2. #2
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    4.043
    Wie bitte sollen wir die helfen, wenn du dich im ungefähren vagen bewegst. Was soll "nimmt der jetzt so nicht", "gehts einfach nicht" heißen?

    Naja, wenn du nicht in der Lage bist, selbst die korrekte inputenc-Option rauszufinden, lass selinput die Arbeit machen:

    Code:
    \documentclass{article}
    \usepackage{selinput}
    \SelectInputMappings{
    adieresis={ä},
    germandbls={ß},
    Euro={€},
    }
    \usepackage[T1]{fontenc}
    \begin{document}
    öäü
    \end{document}

  3. #3
    Registrierter Benutzer
    Registriert seit
    31.03.2010
    Beiträge
    1.039
    Wie in letzter Zeit schon mehrfach empfehle ich auch dieses mal wieder das Paket selinput. Zur richtigen Anwendung des Pakets sei auf die Anleitung verwiesen.

    PS: Ich glaube, ich mache für heute Schluss. Ulrike ist ohnehin immer einen Wimpernschlag schneller.

  4. #4
    Registrierter Benutzer
    Registriert seit
    25.10.2011
    Beiträge
    9
    habs gefunden! ..unfassbar!

    Einstellungen > Dokumente > Editor so konfigurieren, dass er das automatisch ersetzt

    Thread kann geschlossen werden.

  5. #5
    Registrierter Benutzer
    Registriert seit
    25.10.2011
    Beiträge
    9
    hoppala! Danke natürlich für die beiden Antworten. Werde mir das bei Gelegenheit zu Gemüte führen müssen, da meine Lösung explizit für die Umlaute ÄÖÜ geht, und zb NICHT für € ..

    Daaaanke anyway

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •