Anzeige:
Ergebnis 1 bis 7 von 7

Thema: BibTex, Kurzzitat im Literaturverzeichnis voranstellen

  1. #1
    Registrierter Benutzer
    Registriert seit
    06.03.2011
    Beiträge
    15

    Exclamation BibTex, Kurzzitat im Literaturverzeichnis voranstellen

    Hi,

    ich benutze Lyx v1.6.9, JabRef v2.6, und BibTex v0.99d (in MikTex enthalten).

    Als Zitierstil wird jurabib verwendet.

    Im Menü unter Dokumente->Einstellungen->Latex-Vorspann habe ich den unten folgenden Code eingefügt, womit die Literaturliste und Zitate (als Fußnoten) nach meinen Bedürfnissen angezeigt werden.
    Es fehlt nur dass in der Literaturliste jedem Eintrag noch ein Kurzzitat vorangestellt wird.

    Zitat sieht in der Fußnote so aus:
    1(hochgestellt) Däniken 2002, S.24.

    In der Literaturliste momentan falsch so:
    Däniken, Erich, Archäologie in Ägypten, 9. Auflage, Genf 2002

    Sollte aber richtig so aussehen, mit vorangestellten Kurzzitat wie in der Fußnote (damit es einfacher zu finden ist):
    Däniken 2002
    Däniken, Erich, Archäologie in Ägypten, 9. Auflage, Genf 2002


    Ist das mit dem Latex-Vorspann machbar, oder muss dazu die BST-Datei umgeschrieben werden (BibTex-Style Datei)?
    Es geht hier zuerst nur darum VOR dem eigentlichen Literaturverzeichnis-Eintrag AUTOR JAHR voranzustellen, in einer eigenen Zeile.

    Code:
    % Latex-Vorspann in Lyx
    \usepackage{soul}
    
    \usepackage{jurabib}
    
    \usepackage{setspace}
    
    \jurabibsetup{
    human,
    super,
    %authorformat=smallcaps,
    authorformat=year,
    bibformat=compress,
    bibformat=ibidem,
    commabeforerest=true,
    titleformat=commasep,
    pages=format,
    dotafter=bibentry,
    howcited=normal,
    ibidem=strict,
    idem=strict,
    see=true
    }
    
    \renewcommand*{\jbcitationyearformat}[1]{#1}
    
    \AddTo\bibsgerman{
    \renewcommand*{\ibidemname}{Ebd.}
    \renewcommand*{\ibidemmidname}{ebd.}
    \renewcommand{\Bibchaptername}{Kapitel}
    \renewcommand{\editorname}{(Hrsg.)}
    \renewcommand{\inname}{in: }
    \renewcommand\bibidemSfname{Dies.}%
    \renewcommand\bibidemsfname{dies.}%
    }
    
    \renewcommand*{\bibbtsep}{in: }
    \renewcommand*{\bibjtsep}{in: }
    
    \renewcommand*{\bibansep}{, }
    \renewcommand*{\bibatsep}{,}
    \renewcommand*{\bibbdsep}{}
    \renewcommand*{\bpubaddr}{}
    
    \renewcommand*{\bibbtasep}{ fut }
    \renewcommand*{\bibbfsasep}{, }
    \renewcommand*{\bibbstasep}{ fut }
    \renewcommand*{\bibbtesep}{ fut }
    \renewcommand*{\bibbfsesep}{, }
    \renewcommand*{\bibbstesep}{ fut }
    
    \renewcommand*\artnumberformat[1]{\unskip,\space\Numbername~#1}%
    
    \DeclareRobustCommand{\bibaesep}{\bibefnfont{, }}
    
    \DeclareRobustCommand{\jbaensep}{,}
    
    \renewcommand*{\biblnfont}{\normalfont}
    \renewcommand*{\bibfnfont}{\normalfont}
    \renewcommand*{\bibelnfont}{\normalfont}
    \renewcommand*{\bibefnfont}{\normalfont}
    
    \renewcommand*{\bibtfont}{\ul}
    \renewcommand*{\bibbtfont}{\ul}
    \renewcommand*{\bibjtfont}{\ul}
    \renewcommand*{\bibapifont}[1]{\glqq#1\grqq}
    
    \AddTo\bibsgerman{\renewcommand*{\urldatecomment}{Zugriffsdatum: }}
    \renewcommand*{\bibbudcsep}{, }
    \renewcommand*{\biburlprefix}{, abrufbar unter }
    \renewcommand*{\biburlsuffix}{}
    \biburlfont{same}
    
    \renewcommand{\citealt}{\cite}
    Wenn ich die Option howcited=all statt howcited=normal nutze, dann erscheint so ein Kurzzitat am Ende des Literatureintrages - aber nicht am Anfang...

  2. #2
    Registrierter Benutzer
    Registriert seit
    06.03.2011
    Beiträge
    15
    Hmm, NATDIN.BST macht genau das mit dem Kurzzitat voranstellen. Aber da geht die SUPER OPTION nicht, damit die Zitat-Nummer hochgestellt wird.

    Super-Option funktioniert bei mir nur mit Jurabib, bei Natbib (Natdin) geht es nicht. Obwohl ich unter Latex-Vorspann folgendes eingefügt habe:
    Code:
    \usepackage[super, numbers]{natbib}
    Hier noch die natbib.cfg für natdin.bst, welche das Voranstellen des Kurzzitats macht. Kann man so eine CFG-Datei für jurabib erstellen? Dann wäre das Problem gelöst.

    Code:
    %  NATBIB.CFG         in Verbindung mit natbib.sty         
    %		      Lorenzen, 2006-01-02
    %		      diese Konfigurationsdatei wird zuletzt eingelesen und
    %		      enth"alt die lokal gew"unschten Einstellungen f"ur den
    %		      Bibliographie-- und Zitierstil
    
    \newcommand{\bibstyle@natdin}%
         {\bibpunct{(}{)}{;}{a}{}{,~}
         \gdef\NAT@biblabelnum##1{\textbf{##1}\\}}
    %%  nach dieser Definition wird das label (dinatlabel) fett geschrieben, dann Zeilenumbruch;
    %%  darunter der bibliographische Beleg
    
    
    \bibstyle@natdin
    
    %% Einzug der Belege nach der Einordnungsmarke
    \setlength{\bibhang}{7mm}

  3. #3
    Registrierter Benutzer
    Registriert seit
    06.03.2011
    Beiträge
    15
    Ohne Programmierkenntnisse ist da wohl wenig zu machen.

    Ich benötige die Zitierweise nach DAI (Deutsches Archäologisches Institut):
    http://www.dainst.org/publikationsrichtlinien
    Zitiernormen:
    1. Veröffentlichungen in Zeitschriften und Monographien basieren grundsätzlich auf dem Fußnotensystem.
    2. Autor-Jahr-System: In den Anmerkungen wird für jedes zitierte Werk ein Kurzzitat verwendet, bestehend aus dem Namen des Autors und dem Erscheinungsjahr.
      Die Kurzzitate werden in einem Literaturverzeichnis durch vollständige bibliographische Angaben aufgelöst. Das Verzeichnis kann wahlweise ganz ohne Abkürzungen oder unter Verwendung von Sigeln erstellt werden.


    Das Problem ist nun, dass ich
    a) mit natdin.bst zwar im Literaturverzeichnis das richtige Kurzzitat bekomme, aber keine Fußnoten-Zitate erzeugen kann.
    b) mit jurabib.bst zwar Kurzzitate in den Fußnoten (footcite) erzeugen kann, aber keine Kurzzitate im Literaturverzeichnis.

    Kennt jemand eine .bst Datei die beides kann?




  4. #4
    Registrierter Benutzer
    Registriert seit
    06.03.2011
    Beiträge
    15
    Mit BibLaTex statt BibTex scheint es viel einfacher unter Lyx v2.0 (beta3) zu sein.

    Ausserdem wird mit Biblatex auch UTF-8 unterstützt, wenn man entweder
    1. unter Dokumente -> Einstellungen -> Latex Vorspann \usepackage[T2A]{fontenc} einträgt, oder
    2. unter Werkzeuge -> Einstellungen -> Ausgabe -> Latex -> Latex Font Kodierung verwenden: T2A einträgt
    und unter Dokumente -> Einstellungen -> Sprache die Kodierung auf Unicode (utf8) stellt.
    Quelle: http://wiki.lyx.org/Tips/Cyrillic (kyrillisch mit Lyx, kyrillische Schrift)

    Bilbatex unter Lyx installieren/aktivieren geht sehr einfach nach der Anleitung im Lyx-Wiki:
    1. die Datei "biblatex.module" herunterladen, und je nach Betriebsystem in den folgenden Benutzerverzeichnis kopieren (diesen findet man raus mit Menü -> Hilfe -> Über Lyx)
    2. WinXP: in C:\Dokumente und Einstellungen\DeinWindowsUserName\Anwendungsdaten\ lyx20\layouts
    3. Win7: in C:\Users\DeinWindowsUserName\AppData\Roaming\LyX2. 0\layouts
    4. Danach Menü -> Werkzeuge -> Neu Konfigurieren klicken
    5. dann Lyx neustarten
    6. ein Dokument öffnen und unter Dokumente - Einstellungen - Module das "Biblatex-citation-styles" markieren und auf "Hinzufügen" klicken.

    Quelle: http://wiki.lyx.org/BibTeX/Biblatex

    Lyx verwendet die Latex-Distribution MikTex. Sollte das Biblatex Package fehlen (was Lyx mit einer entsprechenden Fehlermeldung quitiert), kann Biblatex sehr einfach über den grafischen Manager installiert werden. Dazu geht man unter Windows -> Alle Programme -> MiKTeX 2.9 -> Maintenance (Admin) -> Package Manager (Admin), wählt in der Liste alles aus was mit "Biblatex" anfängt und klickt auf "+" oder rechte Maustaste install.

    Folgende Einstellungen machen u.a. dass die Zitate als Fußnoten dargestellt werden.
    Dazu in Dokumente -> Einstellungen -> Latex Vorspann folgendes einfügen (biblatex laden):
    Code:
    \usepackage[style=footnote-dw, natbib=true, nopublisher=false]{biblatex}
    Quelle: http://www.golatex.de/problem-mit-ly...-dw-t5862.html

    Und in der Zeile danach noch im Vorspann die mit JabRef erstellte bib-Datei angeben (absoluten Pfad, ohne Endung .bib):
    Code:
    \bibliography{C:/Dokumente/meineBibDatei}
    Dann erstellt man in Dokument eine Notiz mit Einfügen -> Notiz -> Lyx Notiz. Da rein kommt jetzt mit Einfügen -> Liste/Inhaltsverzeichnis -> BibTex Literaturverzeichnis noch die bib-Datei, damit Lyx diese kennt. Das ist sehr wichtig, direkt ins Dokument darf man das "BibTex Literaturverzeichnis" bei BibLatex Verwendung nicht einfügen - nur in Notiz oder Kommentar. Als Stil kann man "plain" lassen, spielt hier keine Rolle.

    Jetzt noch an der Stelle wo die Literaturliste erscheinen sollte mit Einfügen -> Tex Code (ERT) erstellen und dort folgendes reinschreiben:
    Code:
    \printbibliography
    Fertig.
    Jetzt muss ich nur noch die korrekte Darstellung nach DAI hinbekommen...

    ---
    Lyx Beispieldateien für Biblatex:
    http://wiki.lyx.org/BibTeX/Biblatex#toc8

    ---
    Gute Anleitung für Anfänger zu JabRef / Bibtex / Literaturliste:
    http://www.philipphauer.de/tut/lyx-bibtex-jabref.php

    ---
    und so sieht es mit Latex 2.0 (beta3) und BibLatex aus:


    ---
    Hier noch die Datei biblatex.module, welche ins Layout Verzeichnis kommt:
    Code:
    #\DeclareLyXModule{Biblatex-citation-styles}
    #DescriptionBegin
    #A prerequisite for using the biblatex package. This module simply
    #enables the author/year citation styles without actually loading natbib.
    #Biblatex itself needs to be loaded manually. Cf.
    #http://wiki.lyx.org/BibTeX/Biblatex
    #DescriptionEnd
    
    Format 11
    
    # this is biblatex actually
    Provides natbib		1
    Geändert von peterpan (27-03-2011 um 15:42 Uhr) Grund: Datei biblatex.module hinzugefügt

  5. #5
    Registrierter Benutzer
    Registriert seit
    06.03.2011
    Beiträge
    15
    Weiss jemand wie man es bei Biblatex macht, dass ein Kurzzitat im Literaturverzeichnis erscheint (wie im NATDIN Bild ganz oben)?

    Mit Google finde ich dazu nichts. Habe bereits auch viele Stile und Beispiele durchgesehen, und niergendwo gibt es ein Beispiel mit so einem Kurzzitat im Literaturverzeichnis

  6. #6
    Registrierter Benutzer Avatar von lockstep
    Registriert seit
    31.08.2008
    Beiträge
    1.488
    Diese Frage habe ich vor kurzem sowohl hier als auch hier beantwortet.

    lockstep
    idxlayout - Konfigurierbares Index-Layout, kompatibel mit KOMA-Script und memoir

  7. #7
    Registrierter Benutzer
    Registriert seit
    06.03.2011
    Beiträge
    15
    Hi, danke für die Antwort

    Das Problem: ich finde unter Windows XP weder im MikTex-Ordner noch im Lyx-Ordner keine einzige *.bbx oder *.cbx Datei, die ich dann ändern könnte.

    Es gibt lediglich in MikTex die Dateien biblatex.tpm, biblatex-dw.tpm, biblatex-historian.tpm, usw.

    Weiss jemand wo sich diese .bbx und .cbx Dateien befinden?

    Lyx ist sehr einfach und leicht für alle "Nicht-Informatiker". Das einzige große Problem ist bisher lediglich die Literaturliste und Zitierweise. Einfache und für Nicht-Informatiker verständliche Dokumentationen und Anleitungen (wie diese hier: http://www.philipphauer.de/tut/lyx-bibtex-jabref.php ) gibt es leider fast gar nicht. Wer hat nur soviele Zitierstile erfunden?
    Anscheinend gibt es leider nicht viele Archäologen, die Lyx / Latex verwenden. Beziehungsweise gibt es wohl kaum Archäologen die gleichzeitig Informatiker sind und fertige Stile für Bibtex / Biblatex bereitstellen können (nach diesen Richtlinien: http://www.dainst.org/publikationsrichtlinien ).

    Hier noch die Lyx-Datei:
    Code:
    #LyX 2.0.0beta3 created this file. For more info see http://www.lyx.org/
    \lyxformat 410
    
    \begin_document
    \begin_header
    \textclass scrartcl
    
    \begin_preamble
    \usepackage[T2A]{fontenc}
    \widowpenalty=10000
    \clubpenalty=10000
    \usepackage[style=footnote-dw, natbib=true, backref=true, edsuper=true, namefont=smallcaps, nopublisher=false]{biblatex}
    \bibliography{c:/bibtex_utf8_test1}
    \end_preamble
    
    \use_default_options false
    
    \begin_modules
    biblatex
    \end_modules
    
    \maintain_unincluded_children false
    \language english
    \inputencoding utf8
    \fontencoding global
    \font_roman default
    \font_sans default
    \font_typewriter default
    \font_default_family default
    \use_non_tex_fonts false
    \font_sc false
    \font_osf false
    \font_sf_scale 100
    \font_tt_scale 100
    
    \graphics default
    \default_output_format default
    \output_sync 0
    \bibtex_command default
    \index_command default
    \float_placement t
    \paperfontsize default
    \spacing onehalf
    \use_hyperref false
    \papersize a4paper
    \use_geometry false
    \use_amsmath 1
    \use_esint 1
    \use_mhchem 0
    \use_mathdots 1
    \cite_engine natbib_authoryear
    \use_bibtopic false
    \use_indices false
    \paperorientation portrait
    \suppress_date false
    \use_refstyle 0
    \index Index
    \shortcut idx
    \color #008000
    \end_index
    \secnumdepth 3
    \tocdepth 3
    \paragraph_separation indent
    \paragraph_indentation default
    \quotes_language danish
    \papercolumns 1
    \papersides 2
    \paperpagestyle default
    \tracking_changes false
    \output_changes false
    \html_math_output 0
    \html_be_strict false
    \end_header
    
    \begin_body
    
    \begin_layout Standard
    Testtext
    
    \begin_inset CommandInset citation
    LatexCommand citep
    key "Gates2009"
    \end_inset
    
    Testtext
    \begin_inset CommandInset citation
    LatexCommand citep
    key "Tolstoj1955"
    
    \end_inset
    
    \end_layout
    
    \begin_layout Standard
    \begin_inset Note Note
    status open
    \begin_layout Plain Layout
    \begin_inset CommandInset bibtex
    LatexCommand bibtex
    bibfiles "bibtex_utf8_test1"
    options "plain"
    \end_inset
    
    
    \end_layout
    
    \end_inset
    
    
    \end_layout
    
    \begin_layout Standard
    \begin_inset ERT
    status open
    \begin_layout Plain Layout
    \backslash
    printbibliography
    \end_layout
    \end_inset
    
    
    \end_layout
    
    \end_body
    \end_document
    Edit:
    Wenn man in Lyx im Latex-Vorspann folgendes eingibt, erscheinen alle Zitate als Fußnoten, auch mit style=authoryear:
    Code:
    \let\citet\footcite
    \let\citep\footcite
    Quelle: http://www.golatex.de/autor-jahr-sti...lyx-t5900.html

    Und hier steht noch, wie man eigene Stile in Biblatex erstellen kann:
    http://biblatex.dominik-wassenhoven.de/dtk.shtml

    Hier noch was gefunden, wie man in Zitaten das Komma zwischen Autor und Jahr entfernt (style=authoryear). Am besten man verwendet natbib=true nicht, oder benutzt \renewcommand\nameyeardelim{ } im Latex-Vorspann:
    http://www.freak-search.com/de/threa...eite_mit_komma

    Momentan sieht mein Latex-Vorspann so aus, und die Zitate sehen schon mal nach DAI-Richtlinien aus:
    Code:
    \usepackage[
       style = authoryear,
       maxnames = 2, % bei mehr als zwei Namen: et al.
       % natbib = true, % zur Verwendung der alten Befehle
       firstinits = true, % Abkürzung des Vornamens auf ersten Buchstaben
       % terseinits = true, % Punkt hinter abgekürztem Vornamen weg
       sortcites = true % sortiert die Zahlen im Zitat der Reihenfolge
       ]{biblatex}
    \bibliography{c:/bibtex_utf8_test1}
    \let\citet\footcite
    \DeclareFieldFormat{postnote}{#1} % S. vor Seitenzahl entfernen
    Geändert von peterpan (28-03-2011 um 03:02 Uhr) Grund: Lyx-Quellcode hinzugefügt

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •