Anzeige:
Ergebnis 1 bis 11 von 11

Thema: Lyx: Doppelseitig drucken

  1. #1
    Registrierter Benutzer
    Registriert seit
    07.01.2007
    Beiträge
    48

    Lyx: Doppelseitig drucken [wieder UNgelöst]

    Hallo zusammen,

    ich nutze Lyx und ich habe eingestellt, dass doppelseitig gedruckt werden soll.

    Zudem nutze ich Seitenumbrüche.

    BEVOR ich doppelseitig gedruckt habt, wurde der Text vertikal nach oben zentriert. Dann kam der Seitenumbruch und es ging normal auf der nächsten Seite weiter.

    NACHDEM ich jetztdoppelseitig drucke, wird der Text vertikal zentriert, was ich bescheiden aussieht.

    Wie folgt:
    Das sieht gut:

    %% LyX 1.6.5 created this file. For more info, see http://www.lyx.org/.
    %% Do not edit unless you really know what you are doing.
    \documentclass[12pt,a4paper,ngerman,bibtotocnumbered]{scrreprt}
    \usepackage[T1]{fontenc}
    \usepackage[latin9]{inputenc}
    \pagestyle{headings}
    \setcounter{secnumdepth}{3}
    \setcounter{tocdepth}{3}
    \setlength{\parskip}{\medskipamount}
    \setlength{\parindent}{0pt}
    \usepackage{float}
    \usepackage{setspace}
    \onehalfspacing
    \usepackage{babel}
    \begin{document}
    \chapter{Beschreibung der Stichprobe}
    \textbf{Ausfüllende des Fragebogens}\\
    blablabla\\
    \pagebreak{}\textbf{Schulbildung}\\
    blablabla
    \end{document}


    ---> wenn ich aber diese Zeile ändere
    \documentclass[12pt,a4paper,ngerman,bibtotocnumbered]{scrreprt}
    zu
    \documentclass[12pt,a4paper,twoside,ngerman,bibtotocnumbered]{scrreprt}

    --> dann wird zentriert.

    Das möchte ich verhindern...aber wie?

    Viele Grüße,
    fischmir
    Geändert von fischmir (01-09-2010 um 20:23 Uhr)

  2. #2
    Registrierter Benutzer
    Registriert seit
    31.03.2010
    Beiträge
    1.039
    Absätze mach man nicht mit \\, sondern mit \par oder Leerzeile. Überschriften wie "Schulbildung" macht man nicht mit \textbf{Schulbildung}, sondern mit einem Überschriftenbefehl, beispielsweise \minisec{Schulbildung}. Eine neue Seite beginnt man nicht mit \pagebreak, sondern mit \newpage oder \clearpage. Wenn Du das alles beachtest, dürfte das Problem von alleine verschwinden.

  3. #3
    Registrierter Benutzer
    Registriert seit
    07.01.2007
    Beiträge
    48
    Das kann zwar sein, aber ich nutze leider lyx - soll heißen, den Code habe ich nicht selber erstelle, sondern Lyx.

    Das einzige was ich machen kann, sind Einstelungen in Lyx ändern oder weitere Zeilen in den Vorspann einfügen. Deine Hinweise helfen mir leider nicht weiter...

  4. #4
    Registrierter Benutzer
    Registriert seit
    06.03.2010
    Ort
    St. Petersburg, Russland
    Beiträge
    2.454
    Du kannst ja wohl in Lyx einen normalen Absatz mit der Enter-Taste setzen (gibt im LaTeX-Code eine Leerzeile), anstatt oben im Menü einen Zeilenumbruch zu suchen.
    Und die Optionen pagebreak, newpage und clearpage gibt es da oben alle.
    Man kann auch LaTeX-Code direkt in den Text einfügen als "evil red text" (ERT), was aber natürlich bei Leerzeilen für Absätze nicht viel Sinn macht.

  5. #5
    Registrierter Benutzer
    Registriert seit
    07.01.2007
    Beiträge
    48
    Okay, ich habe die Sachen geändert; siehts das nun besser aus? Das Problem besteht aber weiterhin...

    Code:
    %% LyX 1.6.5 created this file.  For more info, see http://www.lyx.org/.
    %% Do not edit unless you really know what you are doing.
    \documentclass[12pt,a4paper,twoside,ngerman,bibtotocnumbered]{scrreprt}
    \usepackage[T1]{fontenc}
    \usepackage[latin9]{inputenc}
    \pagestyle{headings}
    \setcounter{secnumdepth}{3}
    \setcounter{tocdepth}{3}
    \setlength{\parskip}{\medskipamount}
    \setlength{\parindent}{0pt}
    \usepackage{float}
    \usepackage{setspace}
    \onehalfspacing
    \usepackage{babel}
    
    \begin{document}
    
    \chapter{Beschreibung der Stichprobe}
    
    bla\pagebreak{}bla
    \end{document}

  6. #6
    Registrierter Benutzer
    Registriert seit
    06.03.2010
    Ort
    St. Petersburg, Russland
    Beiträge
    2.454
    Und wenn du den Seitenumbruch auch noch änderst?
    Bei \pagebreak versucht er, die Seite "voll" zu kriegen, und wenn bei deinem Dokument \flushbottom (und nicht \raggedbottom) Standard ist, verteilt er die vorhandenen Elemente möglichst gleichmäßig auf der Seite und gibt eine "underfull \vbox"-Meldung aus.
    Bei \clearpage hingegen hört er in jedem Fall da mit der Seite auf, wo er gerade ist, und fängt eine neue an.

  7. #7
    Registrierter Benutzer
    Registriert seit
    07.01.2007
    Beiträge
    48
    Ja, super! Das wars...!!

    Ich habe verwendet: Lyx -> Einfügen -> Formatierung -> Seitenumbruch (dann wird der Rest auf der Seite zenteriert)

    Richig ist: Lyx -> Einfügen -> Formatierung -> Neue Seite...

    Danke!

    Gruß,
    fischmir

    PS: Schreibe nicht selber, sondern meine Freundin, sonst wäre mit "Neue Seite" vielleicht schonmal eher aufgefallen...

  8. #8
    Registrierter Benutzer
    Registriert seit
    07.01.2007
    Beiträge
    48

    ...und schon wieder....

    Hallo,

    jetzt habe ich wieder das gleiche problem:

    Bei folgendem Code rutscht blablabla nach ganz unten auf der ersten Seite. Auf der zweiten Seite beginnt dann der weitere Text?

    Diesmal gibt es aber keinen Seitenubruch o.ä. Eine IDee, woran das liegen könnte?

    Gruß,
    fischmir


    Code:
    %% LyX 1.6.7 created this file.  For more info, see http://www.lyx.org/.
    %% Do not edit unless you really know what you are doing.
    \documentclass[12pt,twoside,ngerman,bibtotocnumbered]{scrreprt}
    \usepackage[T1]{fontenc}
    \usepackage[latin9]{inputenc}
    \usepackage[a4paper]{geometry}
    \geometry{verbose,tmargin=2.5cm,bmargin=2cm,lmargin=2cm,rmargin=3cm,headheight=1.5cm,headsep=1cm,footskip=1.25cm}
    \pagestyle{headings}
    \setcounter{secnumdepth}{3}
    \setcounter{tocdepth}{3}
    \setlength{\parskip}{\medskipamount}
    \setlength{\parindent}{0pt}
    \usepackage{array}
    \usepackage{float}
    \usepackage{setspace}
    \onehalfspacing
    
    \makeatletter
    
    %%%%%%%%%%%%%%%%%%%%%%%%%%%%%% LyX specific LaTeX commands.
    %% Because html converters don't know tabularnewline
    \providecommand{\tabularnewline}{\\}
    
    \makeatother
    
    \usepackage{babel}
    
    \begin{document}
    
    \chapter{Bla}
    
    %
    \begin{table}[H]
    {\footnotesize }\begin{tabular}{>{\raggedright}p{0.4\textwidth}}
    {\footnotesize bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    a bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla a bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla bla
    bla bla bla bla }\tabularnewline
    \end{tabular}
    \end{table}
    
    
    {\footnotesize }%
    \begin{figure}[H]
    {\footnotesize }\begin{tabular}{>{\centering}p{0.47\textwidth}}
    {\footnotesize ich bin eigentlich ein Bild ich bin eigentlich ein
    Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich bin
    eigentlich ein Bild ich bin eigentlich ein Bild ich bin eigentlich
    ein Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich
    bin eigentlich ein Bild ich bin eigentlich ein Bild ich bin eigentlich
    ein Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich
    bin eigentlich ein Bild ich bin eigentlich ein Bild ich bin eigentlich
    ein Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich
    bin eigentlich ein Bild ich bin eigentlich ein Bild ich bin eigentlich
    ein Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich
    bin eigentlich ein Bild ich bin eigentlich ein Bild ich bin eigentlich
    ein Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich
    bin eigentlich ein Bild ich bin eigentlich ein Bild ich bin eigentlich
    ein Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich
    bin eigentlich ein Bild ich bin eigentlich ein Bild ich bin eigentlich
    ein Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich
    bin eigentlich ein Bild ich bin eigentlich ein Bild ich bin eigentlich
    ein Bild ich bin eigentlich ein Bild ich bin eigentlich ein Bild ich
    bin eigentlich ein Bild ich bin eigentlich ein Bild }\tabularnewline
    \end{tabular}{\footnotesize \par}
    
    {\footnotesize \caption{Beschreibung erste Tabelle}
    }
    \end{figure}
    
    \end{document}

  9. #9
    Registrierter Benutzer
    Registriert seit
    06.03.2010
    Ort
    St. Petersburg, Russland
    Beiträge
    2.454
    Weil das, was danach kommt, nicht mehr darunter auf die Seite passt.
    Schreib doch \raggedbottom in die Präambel, wenn du oft solche Sachen hast und es dir egal ist, ob der untere Seitenrand überall bündig ist.
    Eigentlich sieht es bei zweiseitigen Dokumenten halt besser aus, wenn beide Seiten auch unten gleich abschließen. Und so ein paar einzelne Problemfälle, bei denen man "underfull \vbox"-Meldungen bekommt, kann man ja auch durch Umformulieren, \enlargethispage und manuelle Seitenumbrüche lösen (ganz zum Schluss, wenn du nichts mehr am Satzspiegel und am Text ändern willst).

  10. #10
    Registrierter Benutzer
    Registriert seit
    07.01.2007
    Beiträge
    48
    Na klar, jetzt wo du es sagst, macht das sogar Sinn rstuby

    Vielen Dank für deine äußerst kompetente und schnelle Hilfe..!

    fischmir

  11. #11
    Registrierter Benutzer
    Registriert seit
    31.03.2010
    Beiträge
    1.039
    Zitat Zitat von rstuby Beitrag anzeigen
    Schreib doch \raggedbottom in die Präambel, wenn du oft solche Sachen hast und es dir egal ist, ob der untere Seitenrand überall bündig ist.
    Wobei die bessere Lösung sein dürfte, die Gleitumgebungen einfach gleiten zu lassen, statt sie mit Option H (und vermutlich dem Paket float) festzunageln und damit ad absurdum zu führen. Welche Einstellung von LyX für das \begin{table}[H] zuständig ist und wie man das in \begin{table}[htbp] oder ein schlichtes \begin{table} ändern kann, weiß ich nicht.

    Die ebenfalls vorhandenen sinnlosen Anweisungen im Code lasse ich jetzt mal unberücksichtigt, da ich nicht weiß, ob die LyX automatisch verzapft oder ob man die selbst zu verantworten hat.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •