Anzeige:
Ergebnis 1 bis 7 von 7

Thema: Unterpunkte im Inhaltsverzeichnis nicht einrücken

  1. #1
    Registrierter Benutzer
    Registriert seit
    20.05.2009
    Ort
    Würzburg
    Beiträge
    38

    Unterpunkte im Inhaltsverzeichnis nicht einrücken

    Hallo, ich habe folgendes Problem.
    Mein Betreuer möchte, dass die Unterpunkte im Inhaltsverzeichnis NICHT eingerückt sind (warum auch immer...), d.h. er möchte es so haben

    1. kapitel 1
    1.1 erster unterabschnitt
    1.2 zweiter unterabschnitt
    1.2.1
    1.2.2
    2. kapitel 2
    2.1 ersterunterabschnitt
    etc.

    Weiß da jemand eine Möglichkeit mein Inhaltsverzeichnis auf diese Art und weise zu ändern? Vielen Dank schonmal!

  2. #2
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.732
    Moin moin,
    Zitat Zitat von itzibi Beitrag anzeigen
    Mein Betreuer möchte, dass die Unterpunkte im Inhaltsverzeichnis NICHT eingerückt sind
    so Du eine (halbwegs aktuelle) KOMA-Klasse nutzt, sollte das mit
    Code:
    \documentclass[toc=flat]{scr...}
    machbar sein.

    MfG
    Rainer
    There's nothing a good whack with a hammer won't fix!

  3. #3
    Registrierter Benutzer
    Registriert seit
    20.05.2009
    Ort
    Würzburg
    Beiträge
    38
    das klappt leider nicht, weiß auch nicht, ob ich eine KOMA-Klasse verwende, bin blutiger anfänger :-/
    mein dokument sieht vereinfacht wie folgt aus:

    \documentclass[a4paper,11pt]{report}

    \begin{document}

    \tableofcontents

    \chapter{Einleitung}
    \section{Unterkapitel 1}
    \section{Unterkapitel 2}

    \chapter{2. Kapitel}
    \section{wieder ein unterkapitel}
    \section{und noch eins}
    \subsection{auch hier soll nicht eingerückt werden}
    \subsection{hier auch nicht}

    \newpage\addcontentsline{toc}{chapter}{Abbildungsv erzeichnis}\listoffigures

    \end{document}


    hat jemand noch eine neue Idee??
    danke schonmal
    Grüße
    itzibi

  4. #4
    Registrierter Benutzer Avatar von mechanicus
    Registriert seit
    10.07.2008
    Ort
    Hamburg
    Beiträge
    3.944
    Zitat Zitat von itzibi Beitrag anzeigen
    das klappt leider nicht, weiß auch nicht, ob ich eine KOMA-Klasse verwende, bin blutiger anfänger :-/
    Du nutzt erstmal keine KOMA-Klasse.
    Falls du wechseln willst, einfach wie folgt deinen Dokumentenkopf ändern:
    \documentclass[a4paper,11pt,toc=flat]{scrreport}

    Willst du nicht wechseln, so nehme das Paket tocloft:

    Code:
    \documentclass[a4paper,11pt,toc=flat]{scrreprt}
    
    % \documentclass[a4paper,11pt]{report}
    % \usepackage{tocloft}
    % \setlength{\cftchapnumwidth}{2.5em}
    % \setlength{\cftsecnumwidth}{2.5em}
    % \setlength{\cftsubsecnumwidth}{2.5em}
    % \setlength{\cftsecindent}{0em}
    % \setlength{\cftsubsecindent}{0em}
    
    \begin{document}
    
    \tableofcontents  
    
    \chapter{Einleitung}
    \section{Unterkapitel 1}
    \section{Unterkapitel 2}
    
    \chapter{2. Kapitel}
    \section{wieder ein unterkapitel}
    \section{und noch eins}
    \subsection{auch hier soll nicht eingerückt werden}
    \subsection{hier auch nicht}
    
    \newpage\addcontentsline{toc}{chapter}{Abbildungsverzeichnis}\listoffigures
    
    \end{document}
    Gruß
    Marco

  5. #5
    Registrierter Benutzer Avatar von localghost
    Registriert seit
    01.11.2006
    Ort
    Braunschweig
    Beiträge
    3.413

    Arrow Paket

    Zitat Zitat von itzibi Beitrag anzeigen
    [...] das klappt leider nicht, weiß auch nicht, ob ich eine KOMA-Klasse verwende, bin blutiger anfänger [...]
    Nein, tust Du nicht. Die Klassen von KOMA Script sind eindeutig zu erkennen. Ralf hat das schon angedeutet.

    Nimm das Paket tocloft und setze mit den Längen \cftXindent (X=part,chapter, ...) alle Einzüge auf Null. Lies Abschnitt 2.3 (Typesetting the entries, S. 8ff) der Anleitung und befolge genau die Hinweise.


    MfG
    Thorsten¹
    TeX und LaTeX, Fragen und Antworten – TeXwelt

    ¹ Es tut mir Leid. Meine Antworten sind begrenzt. Sie müssen die richtigen Fragen stellen.
    ² System: openSUSE 13.1 (Linux 3.11.10), TeX Live 2013, TeXworks 0.5 (r1351)

  6. #6
    Registrierter Benutzer
    Registriert seit
    20.05.2009
    Ort
    Würzburg
    Beiträge
    38

    Smile

    JUHU!
    Vielen Dank für die Mühe und z.T. ausführlichen Beschreibungen für report, aber hab jetzt einfach statt report scrreprt geschrieben und toc=flat eingefügt und schon funktionierts perfekt!

  7. #7
    Registrierter Benutzer Avatar von lockstep
    Registriert seit
    31.08.2008
    Beiträge
    1.488
    Wenn dein Betreuer nicht nur die Unterpunkte nicht eingerückt, sondern auch die jeweiligen Unterpunktbezeichnungen direkt nach der Nummerierung haben möchte, kannst du das wie folgt erreichen:

    Code:
    \documentclass{scrreprt}% ohne Option toc=flat
    \usepackage[tocfullflat]{tocstyle}
    \usetocstyle{KOMAlike}
    (Lass dich von der Alpha-Warnung nicht abschrecken, ich benutzte tocstyle seit mehreren Monaten ohne Probleme.) Wenn du im Codebeispiel die Option tocfullflat durch tocflat ersetzt, entspricht dies der Option toc=flat, die du direkt bei der Dokumentklasse scrreprt angeben kannst.

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •