Anzeige:
Ergebnis 1 bis 2 von 2

Thema: Problem mit subfig (mit subfloat / subfigure)

  1. #1
    Fin
    Gast

    Question Problem mit subfig (mit subfloat / subfigure)

    Hallo allerseits!

    Ich habe in einem Dokument das Problem Bilder nebeneinander und (an anderer Stelle) auch untereinander einzufuegen. Einige Beitraege habe ich jetzt schon durch, aber mein Error bleibt hartnaeckig. Daher bitte ich um Loesungsvorschlaege.

    Ein Minimalbeispiel hab ich auch schon vorbereitet (ich hoffe es entspricht der Norm hier im Forum - ist mein erster Beitrag, daher bitte ich um Nachsicht)

    Code:
    \documentclass[12pt]{scrreprt}
    \linespread{1.5}
    
    \usepackage[T1]{fontenc}
    \usepackage[pdftex]{graphicx}
    \usepackage{wrapfig}
    %\usepackage{subfig} % subfigure --> Nachfolgepaket: subfig
    \usepackage[caption=false]{subfig} % aus mrunix
    \usepackage[subfigure]{tocloft} % aus http://people.ee.ethz.ch/~dominikb/l2picfaq/l2picfaq.pdf (page20)
    \usepackage[hang]{caption} % caption2 --> Nachfolgepaket: caption
    % margin=10pt,font=small,labelfont=bf,format=hang
    \usepackage{textcomp,booktabs,amsmath}
    \usepackage[scaled]{helvet}
    \usepackage[a4paper, left=4.0cm, right=3.5cm, top=3.5cm, bottom=3.5cm]{geometry}       		
    \usepackage{scrpage2}
    \usepackage[Latin1, ansinew]{inputenc}
    \usepackage{SIunits}
    \usepackage{listliketab,tabularx}
    \usepackage[english,ngerman]{babel}
    \usepackage{listings} 
    
    
    \begin{document}
    
    \begin{figure}[h]
    \centering
      \subfloat[cap a]{\label{b1}\includegraphics[width=0.48\textwidth]{../Pics/fig5a.png}} 
      \hfill        
      \subfloat[cap b]{\label{b2}\includegraphics[width=0.48\textwidth]{../Pics/fig5b.png}}
      \caption{nebeneinander}
      \label{fig1}
    \end{figure}
    
    \begin{figure}[h]
    \centering
    	\subfigure[cap1]{\label{b3}\includegraphics[width=1\textwidth]{../Pics/tensile.png}}
    	\subfigure[cap2]{\label{b4}\includegraphics[width=1\textwidth]{../Pics/tensile2.png}}
    \caption{untereinander}
    \label{fig2}
    \end{figure}
    
    \end{document}
    Soweit ich selber dem Problem auf der Spur war liegt die Ursache vermutlich in dem subfig Paket. Wenn ich statt dem neueren subfig das package subfigure benutze, bekomme ich die Bilder untereinander gut hin. Dann aber wird der subfloat auseinander gehauen. Ich formuliere das besser stichpunktartig:

    mit \usepackage{subfig} folgt:
    Bilder mit subfloat (also nebeneinander) sind OK; Error mit den subfigure Bildern

    mit \usepackage{subfigure} folgt:
    Bilder mit subfigure (also untereinander) sind OK; Error mit den subfloat Bildern


    Vielen Dank schon mal!

  2. #2
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.752
    Hallo und Herzlich Willkommen
    Zitat Zitat von Fin Beitrag anzeigen
    mit \usepackage{subfig} folgt:
    Bilder mit subfloat (also nebeneinander) sind OK; Error mit den subfigure Bildern
    was erwartest Du? Das subfigure-Paket stellt den \subfigure-Befehl bereit, aber keinen \subfloat-Befehl ... beim subfig-Paket isses anders herum, also ersetze bei Verwendung des subfig-Pakets alle \subfigure- durch \subfloat-Befehle und gut ist.

    BTW: und schau gleich mal in l2tabu (wenn `texdoc l2tabu' bei Dir versagt: hier) nach `\linespread' ... und vllt im l2picfaq-Dokument nach `Treiberangaben'.

    MfG
    Rainer
    There's nothing a good whack with a hammer won't fix!

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •