PDA

View Full Version : Seite am oberen Rand ausrichten



Münchner
05-02-2013, 11:14
Servus Forenmitglieder,

bei mir richtet TeX die Seiten neuerdings am Seitenende aus. D.h.: wenn ich in einer Seite einen Absatz habe, wird alles nach dem Absatz "nach unten" gezogen, sodass die Seite von unten her befüllt wird.

In der Mitte habe ich dann meistens eine Lücke.
Wie bekomme ich das denn weg, bzw. ist das Problem bekannt?

Ich arbeite auf dem gleichen header wie immer, habe nur die Sprache auf Englisch umgestellt.
\usepackage[english]{babel}
\selectlanguage{english}

Bin dankbar für Rat.
Beste Grüße
Münchner

rstuby
05-02-2013, 11:22
/raggedbottom in die Präambel.

Für zweiseitige Dokumente ist \flushbottom Standard. Sieht besser aus, wenn man zwei Seiten nebeneinander sieht und LaTeX es hinbekommt, die Elemente gut und ohne große Lücken über die Seiten zu verteilen. WEnn es das nicht hinbekommt, ist es wie bei dir und es kommen "underfull \vbox"-Meldungen. Du kannst also auch versuchen, \usepackage{microtype} (zum besseren Berechnen von kleinen Abständen) einzubinden und möglichst alle Absätze mindestens 5-6 Zeilen lang zu machen (damit es mehr Seitenumbruchsmöglichkeiten innerhalb des Absatzes gibt), weniger Überschriften zu benutzen (da diese an sich schon groß sind und dann auch noch ein Seitenumbruch direkt nach der Überschrift verboten ist), evtl "Schusterjungen" im Notfall zuzulassen, wenn du diese jetzt streng verboten hast, und große Objekte wie Bilder und Tabellen auf jeden Fall gleiten zu lassen.

Münchner
05-02-2013, 11:23
\raggedbottom wirkt Wunder,

vielen Dank.

Die microtype package description schreckt mich mit ihren 197 Seiten grad a bisserl ab...

klops
05-02-2013, 14:23
Wenn man berücksichtigt, dass auf Seite 35 die Implementierungsdoku beginnt, die üblicherweise nur für Experten von Interesse ist, dann ist es lange nicht mehr so viel.

rstuby
05-02-2013, 14:39
Ich mache bei microtype nie irgendwas besonderes. Ich binde einfach nur das Paket ein und dadurch wird der Textsatz schöner. Es gibt weniger Meldungen über zu volle und zu leere Boxen, vermutlich auch weniger Trennstriche, und wenn, dann geht der Trennstrich ein Minibisschen über den eigentlichen Textrand hinaus, das sieht insgesamt gerader aus, weil der Strich so dünn ist.

Festus
05-02-2013, 16:36
Ich würde empfehlen, microtype mit der babel-option als


\usepackage[babel]{microtype}

zu laden. Dann werden auch gleich automatisch die richtigen kernings usw. geladen. Dieses Paket leistet wirklich hervorragende Arbeit, und verbessert LaTeX Setz-Routinen noch einmal erheblich. Das geht zwar etwas auf die Rechenleistung, sollte bei einer einigermaßen modernen Maschine aber kein Problem sein. Zum schnellen Durch-Kompilieren kannst du microtype mithilfe der draft-Funktion sonst auch weitestgehend abschalten.

rstuby
05-02-2013, 16:40
Festus, danke für den Tipp! Ist es egal, ob man davor oder danach babel lädt?

Festus
05-02-2013, 16:43
Festus, danke für den Tipp! Ist es egal, ob man davor oder danach babel lädt?

So weit ich weiß sollte man babel vorher laden (das klappt dann auf jeden Fall), ob's andersrum auch geht, weiß ich nicht.

klops
05-02-2013, 18:45
AFAIK spielt die Option derzeit nur bei Verwendung von Englisch oder Französisch eine Rolle. Natürlich stört sie auch sonst nicht. Wenn man immer auf Deutsch schreibt, ist es aber auch nicht tragisch, wenn man sie vergisst.