PDA

View Full Version : Lebenslauf (moderncv): Lesezeichen erscheinen nicht automatisch obwohl im hypersetup



kalli
10-08-2011, 11:43
Hallo, ich möchte, dass wenn meine PDF-Bewerbung unter Windows geöffnet wird, die Lesezeichen-Leiste links automatisch eingeblendet wird. Das klappt bei mir aber nicht.

Hier der Code:



\documentclass[11pt, a4paper]{moderncv}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}


\hypersetup
{
bookmarksopen=true, %öffnet die Lesezeichen in der Seitenleiste
}


\title{}
\firstname{}
\familyname{}


\begin{document}

\section{Sektion 1}
\section{Sektion 2}

\end{document}


Eine Warnung fällt mir dabei ins Auge: Option `pdfpagelabels' is turned off (Occurance: .../hyperref.sty).

tral
10-08-2011, 11:47
Hallo,

du musst schon hyperref einbinden, sonst bringt hypersetup gar nichts...

Christian.

Donalduck
10-08-2011, 11:49
Das macht moderncv automatisch, soweit ich mich richtig erinnere.

tral
10-08-2011, 12:08
Hallo,

und warum kommt dann beim Compilieren:



! Undefined control sequence.
l.6 \hypersetup


?

Christian.

tral
10-08-2011, 12:13
Ah, ich habs. moderncv lädt tatsächlich hyperref (warum auch immer???), aber wahrscheinlich erst ganz zum Schluß. hypersetup muss deswegen nach \begin{document} verschoben werden...

Christian.

kalli
10-08-2011, 13:02
Also bei mir öffnet sich die Lesezeichenleiste unter Windows immer noch nicht. Und bei Euch? Ich sehe nämlich gerade Ihr nutzt Ubuntu - der PDF-Viewer Evince sagt dort aber noch nichts darüber aus, ob sich die Lesezeichenleiste auch unter Windows öffnet.

mechanicus
10-08-2011, 13:17
Hi,

ich nutze zwar auch Ubuntu, aber die Anzeige des Adobe-Readers sollte sich nicht unterscheiden.

In der moderncv.cls findest du folgenden Code:

\AtEndPreamble{
\@ifpackageloaded{CJK}
{\RequirePackage[CJKbookmarks]{hyperref}}
{\RequirePackage[pdftex]{hyperref}}
\AtBeginDocument{
\hypersetup{
breaklinks,
baseurl = http://,
pdfborder = 0 0 0,
pdfpagemode = UseNone,% do not show thumbnails or bookmarks on opening
% pdfstartview = FitH,
pdfstartpage = 1,
pdfcreator = \LaTeX{} with `moderncv' package,
pdfproducer = \LaTeX{},
bookmarksopen = true,
pdfauthor = \@firstname~\@familyname,
pdftitle = \@title,
pdfsubject = \@firstname~\@familyname,
pdfkeywords = \@firstname~\@familyname{} curriculum vit\ae{}}}
\pagenumbering{arabic}% has to be issued after loading hyperref
}

Es ist also schon von Hause aus passend eingestellt. Was hast du für einen Viewer/ was für eine Version von hyperref hast?

Gruß
Marco

tral
10-08-2011, 13:23
Bei mir öffnen sich die Bookmarks sowohl in evince also auch im acroread...

Christian.

kalli
10-08-2011, 13:54
An mechanicus:

Ich versuche es gleich mal ohne eigenes hypersetup
Sollte es dann funktionieren, bleibt noch die Frage wie ich dann ins hypersetup z.B. ein eigenes pdfstartview={FitH} (quasi nachträglich) einschmuggeln kann.
Deine Frage: Habe Ubuntu 10.04 und texlive 2009-7 (neuste Version - Paket texlive-full). Version hyperref weiß ich jetzt nicht. Wird wohl recht aktuell sein.
Deine Frage: Entwicklungsumgebung texclipse. PDF-Viewer ist evince. acroread habe ich nicht.


An tral:
Ich meinte das ansonsten sehr lobenswerte Verhalten von Evince, sich (neben der gemerkten Seitenzahl beim letzten Schließen) auch zu merken ob die Lesezeichenspalte angezeigt werden soll oder nicht. Bei mir ist es so, dass die vom Benutzer gemachte Einstellung über Ansicht|Seitenleiste in Evince ein "bookmarksopen = true" im hypersetup zumindest optisch nicht sichtbar werden läßt.

mechanicus
10-08-2011, 13:57
Hi,

du hast damit eine veraltete Version von LaTeX. Du solltest TL 2011 installieren. Das geht nicht mit Synaptic, sondern nur manuell. Im Wiki von ubuntuusers findest du die passende Anleitung.

Marco

kalli
10-08-2011, 14:41
Vielen Dank erstmal für die bisherige Hilfe!

Bevor ich mir die neuste texlive-Version hole, würde mich aber schon interessieren ob bei Euch mit dem bisherigen Stand unter Windows die Lesezeichen automatisch geöffnet werden.

Vielleicht könnt Ihr ja Eure PDF hier posten, falls Ihr selbst kein Windows auf Eurem Rechner habt. Dann kann ich es selbst ausprobieren.

mechanicus
10-08-2011, 14:46
Hi,

ich habe kein Windows, daher hier das pdf :rolleyes:

Gruß
Marco

u_fischer
10-08-2011, 15:10
bookmarksopen hat nichts mit dem Fenster der Lesezeichen an sich zu tun. Die Option entscheidet ob, die Bookmarks aufgeklappt werden, also ob \subsection usw direkt zu sehen sind.

Das Fenster wird mit \pdfpagemode gesetzt. Der Default von hyperref ist bookmarks=on und pdfpagemode=UseOutlines, d.h. das Fenster müsste normalerweise da sein.

Meine moderncv Version (2010/08/03 v0.12) versucht, das Fenster zu unterdrücken (mit pdfpagemode=UseNone), aber da es das zu spät tut, scheitert es:


"Package hyperref Warning: Option `pdfpagemode' has already been used,
(hyperref) setting the option has no effect on input line 12.


Aber vielleicht ist ja Kallis Version erfolgreicher. Dann kann man das hier versuchen:


\usepackage[pdftex]{hyperref}
\hypersetup{pdfpagemode=UseOutlines}

mechanicus
10-08-2011, 15:26
Der Default von hyperref ist bookmarks=on und pdfpagemode=UseOutlines, d.h. das Fenster müsste normalerweise da sein.

Dann habe ich es stets falsch verstanden. Danke

kalli
10-08-2011, 16:16
An mechanicus:
Unter Windows verhält sich Deine PDF wie gewollt. Das ist also schon mal eine Lösung.

An u_fischer:
Meine moderncv Version ist von 2008 und verhält sich in diesem Punkt genau wie Deine.

Mal was Verrücktes (aus reinem Bastelspaß):
Mit meiner alten Distribution könnte man die PDF mit dem Tool pdfannotextractor bearbeiten und diese dann per (\pdfbookmark?) und \includepdf so einlesen, dass auch unter Windows die Lesezeichen automatisch angezeigt werden. Würde ich nicht weiter verfolgen weil umständlich - müßte aber gehen.

Habe jetzt aber Kopfschmerzen vom vielen abwechselnden Windows/Ubuntu-Booten und mache jetzt erstmal Pause. Der Bootmanager zeigt statt der Einträge für Windows und Ubuntu mittlerweile eh nur noch einen einzigen Eintrag an. Da steht jetzt ... Wubundows :D