PDA

View Full Version : extsizes oder Papierformat



erbse
14-09-2010, 22:08
Hallo,

ich hab an meinen Verlag ein Manuskript in Größe A4 geschickt mit der vom Verlag gewünschten Schriftgröße 12pt. Jetzt hab ich den Probedruck zugeschickt bekommen, der ist wie das Buch in A5 (was ich nicht wusste). Die Schrift ist viel zu klein. HAb zuerst versucht, das Dokument über die Paketoptionen auf A5 umzustellen. Hier das Minimalbeispiel:


\documentclass
[a5paper,
12pt,
twoside,
openright,
bibliography=totocnumbered
]
{scrreprt}

\usepackage[ngerman]{babel}
\usepackage[latin1]{inputenc}
\usepackage[babel,german=quotes]{csquotes}
\usepackage[T1]{fontenc}

\usepackage{bibgerm}
\usepackage[longnamesfirst]{natbib}
\usepackage{chapterbib}

\begin{document}

\include{Vorwort}
%
\include{Emotion}

\end{document}



Beim Kompilieren hab ich folgende Warning erhalten:


Package typearea warning: Maybe no optimal type area settings! The maximum limit of line width is about 18% larger than the heuristically detected line width. You may e.g. increase DIV, decrease fontsize or change the papersize.


Außerdem waren es immer noch DinA4 Seiten....

Dann hab ich ein bisschen im Forum geforscht und hab das extsize-package probiert, um die Schriftgröße zu erhöhen. Hier das Minimalbeispiel:



\documentclass
[a4paper,
17pt,
twoside,
openright,
bibliography=totocnumbered
]
{extreport}

\usepackage[ngerman]{babel}
\usepackage[latin1]{inputenc}
\usepackage[babel,german=quotes]{csquotes}
\usepackage[T1]{fontenc}

\usepackage{bibgerm}
\usepackage[longnamesfirst]{natbib}
\usepackage{chapterbib}

\begin{document}

\include{Vorwort}
%
\include{Emotion}

\end{document}


Die Schrift wurde auch wunderbar größer, nur hab ich folgende Warnung bekommen:


LaTex WArning: Unused global option(s): [bibliography=totocnumbered)


Und wie zu erwarten war, wurde zwar ein Literaturverzeichnis erstellt, tauchte aber nicht im tableofcontents auf. Das soll es aber.

So, und jetzt weiß ich nicht mehr weiter. Habt Ihr eine Idee?

Ganz liebe Grüße,
Jenny

voss
14-09-2010, 22:37
ich hab an meinen Verlag ein Manuskript in Größe A4 geschickt mit der vom Verlag gewünschten Schriftgröße 12pt. Jetzt hab ich den Probedruck zugeschickt bekommen, der ist wie das Buch in A5 (was ich nicht wusste). Die Schrift ist viel zu klein. HAb zuerst versucht, das Dokument über die Paketoptionen auf A5 umzustellen. Hier das

Bleib der KOMA-Script-Klasse, da kannst du auch eine andere Schriftgröße wählen. Aber 17 wäre viel zu groß ...

Herbert

Schweinebacke
15-09-2010, 10:28
Du solltest bei KOMA-Script auch noch die Option "pagesize" ergänzen. Damit sollten dann PDF-Viewer oder PS-Viewer und auch die besseren DVI-Viewer das korrekte Seitenformat anzeigen. Näheres zu der Option ist in der KOMA-Script-Anleitung, scrguide.pdf, zu finden. Dort ist auch einiges über die Wahl ungewöhnlicher Schriftgrößen angegeben. Siehe dazu die Option "fontsize". Im KOMA-Script-Buch ist in Teil II AFAIR noch mehr zu dem Thema zu finden.

nixversteh
15-09-2010, 10:35
Hallo,

ich hab an meinen Verlag ein Manuskript in Größe A4 geschickt mit der vom Verlag gewünschten Schriftgröße 12pt. Jetzt hab ich den Probedruck zugeschickt bekommen, der ist wie das Buch in A5 (was ich nicht wusste). Die Schrift ist viel zu klein. HAb zuerst versucht, das Dokument über die Paketoptionen auf A5 umzustellen. Hier das Minimalbeispiel:


\documentclass
[a5paper,
12pt,
twoside,
openright,
bibliography=totocnumbered
]
{scrreprt}

\usepackage[ngerman]{babel}
\usepackage[latin1]{inputenc}
\usepackage[babel,german=quotes]{csquotes}
\usepackage[T1]{fontenc}

\usepackage{bibgerm}
\usepackage[longnamesfirst]{natbib}
\usepackage{chapterbib}

\begin{document}

\include{Vorwort}
%
\include{Emotion}

\end{document}



Beim Kompilieren hab ich folgende Warning erhalten:


Außerdem waren es immer noch DinA4 Seiten....

Dann hab ich ein bisschen im Forum geforscht und hab das extsize-package probiert, um die Schriftgröße zu erhöhen. Hier das Minimalbeispiel:



\documentclass
[a4paper,
17pt,
twoside,
openright,
bibliography=totocnumbered
]
{extreport}

\usepackage[ngerman]{babel}
\usepackage[latin1]{inputenc}
\usepackage[babel,german=quotes]{csquotes}
\usepackage[T1]{fontenc}
\usepackage{bibgerm}
\usepackage[longnamesfirst]{natbib}
\usepackage{chapterbib}
\begin{document}
\include{Vorwort}
%
\include{Emotion}
\end{document}

Die Schrift wurde auch wunderbar größer, nur hab ich folgende Warnung bekommen:
Und wie zu erwarten war, wurde zwar ein Literaturverzeichnis erstellt, tauchte aber nicht im tableofcontents auf. Das soll es aber.
So, und jetzt weiß ich nicht mehr weiter. Habt Ihr eine Idee?
Ganz liebe Grüße,
Jenny


Hallo Jenny,

füge bitte mal diese Zeile in deine ursprüngliche Präambel ein
DIV=14

dann sollte zumindest diese Meldung *Package typearea warning: Maybe no optimal type area settings! The maximum limit of line width is about 18% larger than the heuristically detected line width. You may e.g. increase DIV, decrease fontsize or change the papersize. * verschwinden

Gruß

Martin

rstuby
15-09-2010, 12:17
Wenn man das Paket hyperref einbindet, werden auch die Seitengrößen korrekt an das pdf weitergegeben (obeohl das Paket eigentlich mehr für Links im pdf zuständig ist).

Auf die DIV-Warnung braucht man bei kleinem Papierformat keine Rücksicht zu nehmen.

u_fischer
15-09-2010, 12:20
Du brauchst die pagesize-Option um eine a5-pdf zu bekommen. 12pt ist für a5 ein bisschen groß, daher die Warnung. Die kannst du aber ignorieren, wenn du willst.


\documentclass[paper=a5,
pagesize,
fontsize=12pt]{scrartcl}

\usepackage{lipsum}
\begin{document}
\lipsum
\end{document}

erbse
19-09-2010, 19:21
Nach langem Rumprobieren:

ich hatte in meinem header das geography-packet geladen und hier A4 als Option eingegeben (warum auch immer...). Deahalb hat das mit dem A5 bei den Optionen bei der Dokumentenklasse nicht geklappt. Also hab ich es jetzt auf A5, 11pt. Und das Geometry-Packet verträgt sich irgendwie nicht mit meinem header, also hab ich DVI=14 bei den Options der Dokumentenklasse eingestellt. Jetzt ist alles fein.

Vielen Dank für Eure Hilfe, hat mir einige neue Erkenntnisse gebracht, auch wenn der Fehler letztendlich an meinen Anweisungen im Header lag. Sorry, dass Ihr Euch deswegen so viel Mühe gemacht habt!

Liebe Grüße,
Jenny