PDA

View Full Version : Kopfzeile



lambda
29-01-2010, 18:11
ich möchte dass die Kopfzeile links oben steht. bei mir steht sie in der MItte.

habe pagestyle{myheadings} und markright{sdsd} benutzt.

lockstep
29-01-2010, 18:15
Welche Klasse verwendest du? Setzt du dein Dokument ein- oder zweiseitig? Verwendest du Zusatzpakete wie fancyhdr oder scrpage2? All das und noch mehr würde uns ein Minimalbeispiel sagen.

lockstep

voss
29-01-2010, 18:30
ich möchte dass die Kopfzeile links oben steht. bei mir steht sie in der MItte.

habe pagestyle{myheadings} und markright{sdsd} benutzt.

Paket fancyhdr laden und dann \pagestyle{fancy}. Doku erhält man
mit texdoc fancyhdr

Herbert

lambda
29-01-2010, 18:37
\documentclass[a4paper, 12pt]{{scrreprt}}
\pagestyle{myheadings}
\markright{}

Ich dachte fancy verträgt sich nicht mit Koma, oder so?

bobmalaria
29-01-2010, 19:12
hi,

doch das geht,

aber nimm doch lieber scrpage2. alles was mit fancyhdr geht geht auch mit scrpage2. ich persöblich finde das paket auch einfacher zu bedienen. die anleitung zu scrpage2 ist in scrguide.pdf enthalten.

gruss

lambda
29-01-2010, 20:57
Also mit myheadings fuinktionierts nicht, da steht dann gar nix. Mit scrheadings klappts. Aber er beginnt nicht ganz oben links, obwohl ich \ohead benutzt habe. Da ich eine längere Kopfzeile habe, überschreibt er eine Stelle 2 mal...

lambda
29-01-2010, 22:18
irgendwie steht die Kopfzeile immer in der Mitte..egalwas ich mache

bobmalaria
30-01-2010, 01:23
hi,

mach doch mal ein kleines! beispiel mit nur dokumentenklasse, scrpage2 paket, pagestyle scrheadsings und eben einer seite mit kopfzeile die dein problem demonstriert.

gruss

lambda
30-01-2010, 12:30
\documentclass[a4paper, 12pt, headsepline,footsepline,]{{scrreprt}}
\usepackage[latin1]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{scrpage2}
\pagestyle{headings}
\ohead{kopfzeile}

\begin{document}


Hallo
\end{document}

Legion
30-01-2010, 13:18
hi,

mach doch mal ein kleines! beispiel mit nur dokumentenklasse, scrpage2 paket, pagestyle scrheadsings und eben einer seite mit kopfzeile die dein problem demonstriert.

gruss


\documentclass[a4paper,12pt,headsepline,footsepline]{scrreprt}
\usepackage[latin1]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{scrpage2}
\ihead{kopfzeile}
\pagestyle{scrheadings}
\begin{document}
Hallo
\end{document}

warum das mit \lehead{} nicht klappt ist mir aber schleierhaft :confused::confused:
a4paper ist übrigens überflüssig, da das die Voreinstellung aller KOMA-Klassen ist.

lambda
30-01-2010, 14:20
Ja nun, steht aber immer noch auch in der Kopfzeile "Inhaltsverzeichnis". Wo kommt da sdenn her?

Legion
30-01-2010, 14:37
In deinem Beispiel steht nirgends Inhaltsverzeichnis. Ohne ein Beispiel dass deinen tatsächlichen Stand widerspiegelt kann man dir auch nicht helfen. Ich weiß nicht was du willst und du lieferst nur häppchenweise Informationen. Du könntest aber z. B. ein
\maunalmark in deine Präambel aufnehmen. Dann verschwindet das "Inhaltsverzeichnis" wieder. Dann musst du aber weitere Kolumnentitel von Hand "zum leben erwecken" ;)

bobmalaria
30-01-2010, 14:41
hi,

wofür steht denn le= left, even. jetzt mal ein buch aufschlagen und schauen wo gerade und ungerade seiten sind. bei einem buch links gerade seiten, das wäre le und bei rechten seiten seiten müsste dass dann doch ro right, odd sein.

da ein einseitiges dokument nur rechte seiten hat, muss man eben auch das richtige feld benutzen :)

wenn man jetzt noch in scrreprt, mit höchster gliederungsebene nach dem inhaltsverzeichnis nur eine \section aufruft, dann steht vermutlich immer noch Inhaltsvz in der kopfzeile.
also einfach mal nach \tableofcontents ein \chapter{Test} starten und die kopfzeile sollte stimmen. dazu am besten auch noch dem paket scrpage2 die automark option mitgeben \usepackage[automark]{scrpage2}

gruss

lambda
30-01-2010, 15:10
hmm mit rohead stehts dann natürlich rechts. Wills aber links. Es kommt immmernoch inhaltsvz. Hier nochmal die "ausführlcihere" datei:


\documentclass[a4paper, 12pt, headsepline,footsepline,]{{scrreprt}}
\usepackage[latin1]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{scrpage2}
\rohead{kopfzeile}

\pagestyle{scrheadings}




\begin{document}


\tableofcontents % Inhaltsverzeichnis
%\listoftables % Tabellenverzeichnis


\newpage


\clearpage
\chapter{Test}
\include{vorwort}
\input{manigfalt}
\input{tangtent}
\include{dualraum}
\include{tensor}
\end{document}

Legion
30-01-2010, 16:25
hi,

wofür steht denn le= left, even. jetzt mal ein buch aufschlagen und schauen wo gerade und ungerade seiten sind. bei einem buch links gerade seiten, das wäre le und bei rechten seiten seiten müsste dass dann doch ro right, odd sein.

da ein einseitiges dokument nur rechte seiten hat, muss man eben auch das richtige feld benutzen :)

wenn man jetzt noch in scrreprt, mit höchster gliederungsebene nach dem inhaltsverzeichnis nur eine \section aufruft, dann steht vermutlich immer noch Inhaltsvz in der kopfzeile.
also einfach mal nach \tableofcontents ein \chapter{Test} starten und die kopfzeile sollte stimmen. dazu am besten auch noch dem paket scrpage2 die automark option mitgeben \usepackage[automark]{scrpage2}

gruss
Brett vorm Kopf gehabt :o Muss natürlich \lohead{} sein, obwohl \ihead{} auch seinen Dienst tut.