mrunix.de

Zurück   mrunix.de > Applikationen > LaTeX-Forum
Benutzername
Kennwort
Registrieren Hilfe Benutzerliste Kalender Suchen Heutige Beiträge Alle Foren als gelesen markieren

LaTeX-Forum LaTeX, LyX, BibteX, PDF & Co

Antwort
 
Themen-Optionen Thema bewerten Ansicht
Alt 03-04-2013, 13:25   #1
Magger
Registrierter Benutzer
 
Registriert seit: 24.04.2009
Beiträge: 168
beamer: subsubsections erzeugen seltsamen Freiraum in infolines

Hallo alle zusammen,

ich habe eine kleines Problem mit dem beamer-Paket in Zusammenhang mit dem Warsaw-Theme.

Folgendes Minimalbeispiel
Code:
\documentclass{beamer} 

\usetheme{Warsaw}

\begin{document}

\section{Test}

\subsection{Test}

\subsubsection{Test 1}

\begin{frame}Leer\end{frame}

\end{document}
funktioniert ganz ohne Probleme.

Erstellt man aber mehr subsubsections wie in dem folgenden Beispiel:
Code:
\documentclass{beamer} 

\usetheme{Warsaw}

\begin{document}

\section{Test}

\subsection{Test}

\subsubsection{Test 1}

\subsubsection{Test 2}

\subsubsection{Test 3}

\subsubsection{Test 4}

\subsubsection{Test 5}

\subsubsection{Test 6}

\begin{frame}Leer\end{frame}

\end{document}
so bekommt man in den infolines am oberen Rand der Folien seltsam viel Freiraum.

Ist das so gewollt oder ein Bug? Das Manual erzählt dazu nicht viel. Die Klassenoption 'compress' verhindert das Ganze übrigens, bringt aber alle sections und subsections auch auf eine Zeile.
Magger ist offline   Mit Zitat antworten
Alt 15-04-2013, 07:51   #2
Magger
Registrierter Benutzer
 
Registriert seit: 24.04.2009
Beiträge: 168
beamer: subsubsections erzeugen seltsamen Freiraum in infolines

Da noch niemand geantwortet hat, möchte ich das Problem gern noch mal durch ein beispielhaftes pdf verdeutlichen.

In der angehängten mb_warsaw_ohne.pdf ist alles so, wie es sein sollte.

In der mb_warsaw_mit.pdf sind weitere subsubsections hinzugefügt, wobei der schon besprochene Leerraum in der Navigationsleiste (infolines) entsteht.
Angehängte Dateien
Dateityp: pdf mb_warsaw_ohne.pdf (23,5 KB, 8x aufgerufen)
Dateityp: pdf mb_warsaw_mit.pdf (24,2 KB, 6x aufgerufen)
Magger ist offline   Mit Zitat antworten
Alt 15-04-2013, 09:01   #3
u_fischer
Registrierter Benutzer
 
Registriert seit: 19.05.2009
Beiträge: 3.689
Das ist ein bug in beamerbasemisc.sty. Da fehlt ein "sub".

Workaround:

Code:
\usetheme{Warsaw}
\makeatletter
\def\beamer@initsubsubsectionentry#1#2#3#4#5#6{\ifnum\beamer@subsubsectionmax<#4\relax\beamer@subsubsectionmax=#4\fi}
\makeatother
Mache einen Bugreport!
__________________
Ulrike Fischer
http://www.troubleshooting-tex.de/
u_fischer ist offline   Mit Zitat antworten
Alt 16-04-2013, 20:45   #4
Magger
Registrierter Benutzer
 
Registriert seit: 24.04.2009
Beiträge: 168
Hallo Ulrike, danke für deine Hilfe.

Ich habe es als Bug gemeldet, siehe https://bitbucket.org/rivanvx/beamer...nge-whitespace.

Viele Grüße, Mathias
Magger ist offline   Mit Zitat antworten
Antwort

Lesezeichen

Themen-Optionen
Ansicht Thema bewerten
Thema bewerten:

Forumregeln
Es ist Ihnen nicht erlaubt, neue Themen zu verfassen.
Es ist Ihnen nicht erlaubt, auf Beiträge zu antworten.
Es ist Ihnen nicht erlaubt, Anhänge hochzuladen.
Es ist Ihnen nicht erlaubt, Ihre Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist an.

Gehe zu


Alle Zeitangaben in WEZ +1. Es ist jetzt 03:23 Uhr.


Powered by vBulletin® Version 3.8.7 (Deutsch)
Copyright ©2000 - 2014, vBulletin Solutions, Inc.