Anzeige:
Ergebnis 1 bis 3 von 3

Thema: Grafiken nach MikTex Update problematisch

Hybrid-Darstellung

Vorheriger Beitrag Vorheriger Beitrag   Nächster Beitrag Nächster Beitrag
  1. #1
    Registrierter Benutzer
    Registriert seit
    21.01.2014
    Beiträge
    7

    Grafiken nach MikTex Update problematisch

    Hallo,


    ich hoffe, jeder hat die Weihnachtsfeiertage gut ueberstanden.


    Nachdem mein erster Laptop mit neun Jahren langsam altersschwach wird, wird gerade ein neuer aufgesetzt. Dabei hat sich gezeigt, dass meine alten MikTEX Dokumente (welche auf dem alten Laptop fehlerfrei laufen und die gewuenschten Ergebnisse bringen) auf dem neuen Laptop nicht mehr richtig uebersetzt werden. Konkret: Grafiken und Bilder verschwinden entweder vollstaendig oder werden in abstrusen Vergroesserungen/Verkleinerungen an beliebigen Stellen des fertigen PDF Dokuments angezeigt, teilweise in den Text 'reinfallend'. Der Durchlauf auf dem neuen System erfolgt jedoch ohne Fehlermeldungen.


    Alter Laptop: MikTEX 2.8, Texnic Center 1.0 (Windows 7)
    Neuer Laptop: MikTEX 2.9, Texnic Center 2.02 (Windows 10)
    "Durchlauf": Option 'LaTeX --> PS --> PDF' im Texnic Center


    Ein lauffaehiges Minimalbeispiel (Optionen bei documentclass werden fuer laengere fertige Dokumente benoetigt) zeigt das ganze Elend:

    Code:
    \documentclass[final,dvips,11pt,a4paper,fleqn,DIV=10,captions=tableheading,listof=totoc,titlepage,oneside]{scrbook}
    
    \usepackage[english]{babel}
    \usepackage[T1]{fontenc}
    \usepackage[ansinew]{inputenc}
    
    \usepackage[dvips]{graphicx}
    \usepackage{blindtext}
    
    
    \begin{document}
    
    \Blindtext
    
    %\rule{5cm}{3cm}
    %\includegraphics{Test}
    
    \Blindtext
    
    \end{document}

    Am wenigsten Probleme hat man, wenn man rule wieder "ein-kommentiert" - Durchlaeufe mit Texnic Center erbringen dann fehlerfreie DVI, PS und PDF Ausgaben mit schwarzem Rechteck an der richtigen Stelle fuer:

    LaTeX --> DVI / LaTeX --> DVI --> PDF / LaTeX --> PDF / LaTeX --> PS

    Lediglich die Option 'LaTeX --> PS --> PDF' ist dann problematisch, da hierbei keinerlei Text aber das schwarze Rechteck an der richtigen Position im PS und PDF angezeigt wird (DVI ist jedoch weiterhin korrekt).


    Will man jedoch anstelle des Rechtecks eine Grafik (Test.eps) einbinden (z.B. von Chem Office oder Corel Draw erzeugt), so ist es fuer keine der genannten Durchlaufoptionen beim Texnic Center moeglich, ein benutzbares PDF zu erhalten (DVI ist in jedem Fall in Ordnung, PS funktioniert fuer 'LaTeX --> PS' aber nicht fuer 'LaTeX --> PS --> PDF':

    LaTeX --> DVI --> PDF: Grafik "faellt in den Text"
    LaTeX --> PDF: Grafik verschwindet vollkommen
    LaTeX --> PS --> PDF: Grafik ist am richtigen Platz des Dokuments, aber es fehlt wieder der gesamte Text des Dokuments


    Ich bin jetzt nach zwei Tagen am Ende meines Lateins - was genau uebersehe ich beim Uebergang von MikTeX 2.8 zu MikTeX 2.9?


    Danke fuer Tips im Voraus,
    phosphorix

  2. #2
    Registrierter Benutzer
    Registriert seit
    19.05.2009
    Beiträge
    4.024
    Wenn du die Option "dvips" (im Kopf und bei graphicx), verwendest, sagst du LaTeX dass du latex+dvips verwenden willst. (LaTeX --> PS). Wenn du dann doch anders kompilierst, kann alles mögliche nicht funktionieren.

    Entferne beide dvips und benütze entweder pdflatex (wahrscheinlich LaTeX-->pdf), oder -- falls du auch pstricks benützt -- LaTeX-->PS. Ggfs solltest du vorher das cm-super-Paket installieren.

  3. #3
    Registrierter Benutzer
    Registriert seit
    21.01.2014
    Beiträge
    7
    Hallo Ulrike,


    dvips scheint das Problem gewesen zu sein - nachdem ich es bei documentclass, graphicx (und in einem anderen Dokument auch bei xcolor) entfernt habe liefert jetzt 'LaTeX --> PDF' verwendbare Ergebnisse fuer das Minimalbeispiel und ein aelteres Dokument.

    Anscheinend Glueck, dass MikTeX 2.8 da keine Probleme gemacht hat.


    Vielen Dank,
    phosphorix

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •