Anzeige:
Ergebnis 1 bis 4 von 4

Thema: Tex-Dokument nach Wechsel Windows -> Linux nicht korrekt, g-brief Fußzeile fehlt

  1. #1
    Registrierter Benutzer
    Registriert seit
    17.06.2017
    Beiträge
    3

    Tex-Dokument nach Wechsel Windows -> Linux nicht korrekt, g-brief Fußzeile fehlt

    Hallo zusammen,

    ich habe erst seit ganz kurzem meinen ersten PC mit Linux 16.04 Cinnamon und versuche gerade, alles "umzuziehen", was ich von meinem bisherigen Windows-PC auf dem neuen PC benötige. Dazu zählen auch meine Bewerbungsunterlagen, die ich mit Latex verfasst habe.

    Unter Windows 7 verwende ich den Texmaker 3.5.2 und die PDFLaTex Übersetzung. Das Dokument ist mit der Klasse g-brief geschrieben. Im g-brief Dokument gibt es oben unter der Kopfzeile und unten über der Fußzeile jeweils einen farbigen Quer-Strich.

    Nun habe ich unter Linux die Pakete texlive-full und texmaker (Version 4.4.1) installiert und die Dokumente vom Windows-Rechner auf den Linux PC kopiert. Die Bewerbung lässt sich problemlos im Texmaker öffnen und ebenfalls mit PDFLaTex übersetzen und eigentlich sieht alles identisch aus bis auf die Fußzeile. Die Unterschrift als Bild ist noch zu sehen. Dann wird der ausgeschriebene Name (der unter der Unterschrift platziert ist) horizontal abgeschnitten und die farbige Linie der Fußzeile ist gar nicht mehr zu sehen.

    Eine Fehlermeldung erhalte ich keine - im Gegenteil, es wird ohne Meldungen übersetzt.
    Übrigens: gleiches Phänomen habe ich auch im Lebenslauf, der mit der Klasse moderncv erzeugt wurde. Da werden die unteren Seitenränder auch irgendwie ignoriert und der Text bis ganz ans untere Blattende fortgeschrieben.

    Folgendes habe ich bereits probiert:
    - Installation unter Linux überprüft (mittels Suche im Netz), ob ich evtl. was vergessen/übersehen habe
    - andere Übersetzer (LaTeX, BibTeX, ...) im Texmaker probiert, die aber nicht funktionieren (da werden dann Fehlermeldungen ausgegeben)
    - in den Optionen die Zeichenkodierung für den Editor geändert auf alles mögliche, aber die beiden Systeme (Windows und Linux) haben beide UTF-8 eingetragen
    - Text im Dokument auskommentiert, damit das Dokument kürzer wird: einziger Effekt -> der ausgeschriebene Name unter der Unterschrift wird nicht mehr horizontal abgeschnitten, aber die farbige Linie der Fußzeile ist immer noch nicht zu sehen

    Ich habe es bisher vermieden, die Texmaker Version unter Windows upzugraden, um zu sehen, ob es mit der neuen Version immer noch unter Windows funktioniert. Denn falls nicht, dann funktionieren beide Rechner nicht mehr für meine Bewerbungen.

    Was mich ebenfalls wundert: bisher hat sich Texmaker so verhalten, dass er automatisch Zeilen auf eine neue Seite gerutscht hat, wenn ihm zu wenig Platz auf der Seite war. Das passiert jetzt nicht, daher gehe ich davon aus, dass es irgendein Problem mit der Seitendarstellung an sich ist. Weiß nur leider nicht mehr, was ich noch versuchen kann und hoffe sehr, ihr könnt helfen!

    Wenn ihr weitere Informationen zu den Systemen oder ein Tex-Minimalbeispiel benötigt, bitte Bescheid geben.

    Danke vorab und Gruß!
    Claudia
    Angehängte Grafiken Angehängte Grafiken
    Angehängte Dateien Angehängte Dateien

  2. #2
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.706
    An Deiner Stelle würde ich erstmal prüfen, ob beide Systeme die gleichen Seitengrößen produzieren
    Code:
    pdfinfo Datei.pdf
    (einmal halt mit der unter Win und einmal mit der unter Linux erstellten pdf)
    -> Page size

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

  3. #3
    Registrierter Benutzer
    Registriert seit
    17.06.2017
    Beiträge
    3
    DANKE, rais!

    Das Seitenformat ist tatsächlich US-Letter. Das ist dann wohl die Ursache.

    Ich habe folgende Optionen in der Klasse eingefügt:
    \documentclass[11pt,ngerman]{g-brief}
    wie auch
    \documentclass[11pt,a4paper]{g-brief}
    Doch Texmaker scheint das völlig zu ignorieren und das PDF ist weiterhin in US-Letter.

    In der Dokumentation vom g-brief steht:
    "Der g-brief dient zur Formatierung vordruckloser Briefe im A4-Format unter LATEX2ε und dem LATEX 2.09 Kompabilit ̈atsmodus von LATEX2ε."

    Also müsste er das doch eigentlich irgendwo im Bauch haben, oder?

    Wie/wo kann ich das noch einstellen? Hab ich was vergessen? Die Option falsch eingefügt?

    Der Lebenslauf ist übrigens ordnungsgemäß im A4-Format, wenn ich diesen separat übersetze.
    \documentclass[11pt,a4paper]{moderncv}

    Nur mit \includepdf[pages=-]{3_Lebenslauf} innerhalb vom g-brief ist er auch im US-Letter Format. Wenn also der g-brief korrekt umgestellt ist, sollte das auch für den Lebenslauf dann erledigt sein. Ist in dem Fall ja ein eingebundenes Dokument.

    Danke für weitere Unterstützung!

    Gruß,
    Claudia

  4. #4
    Registrierter Benutzer
    Registriert seit
    17.06.2017
    Beiträge
    3
    Ich habe nochmal etwas weiter geforscht und im Netz folgenden Beitrag gefunden:
    https://tex.stackexchange.com/questi...for-this-input

    In der Konsole dann
    sudo paperconfig -p a4
    eingetragen und das Tex-Dokument neu übersetzt. DAS war die Lösung! Jetzt funktioniert alles wieder wie es soll!

    DANKE für den super Hinweis!!!

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •