Ergebnis 1 bis 13 von 13

Thema: Schriftart Inhaltsverzeichnis vereinheitlichen

  1. #1
    Registrierter Benutzer
    Registriert seit
    31.07.2009
    Beiträge
    62

    Schriftart Inhaltsverzeichnis vereinheitlichen

    Hallo,
    ich hätte gerne, dass in meinem folgenden Beispiel der Index im Inhaltsverzeichnis in derselben Schriftart wie das andere Kapitel dargestellt wird.
    Was kann ich machen?
    Danke!

    Code:
    \documentclass[12pt,a4paper]{scrbook} 
    
    \usepackage[OT1]{eulervm}
    \usepackage{classicthesis}
    \usepackage{arsclassica} 
    
    \begin{document}
    
    \tableofcontents 
    
    \chapter{Test}
    
    test\index{test}
    
    \addcontentsline{toc}{chapter}{{Index}}  
    
    \end{document}

  2. #2
    Registrierter Benutzer
    Registriert seit
    20.07.2013
    Beiträge
    172
    addcontentsline darfst du gleich aus dem Gedächtnis löschen.
    Code:
    \documentclass[12pt,a4paper,index=totoc]{scrbook} 
    
    \usepackage[OT1]{eulervm}
    \usepackage{classicthesis}
    \usepackage{arsclassica} 
    
    \begin{document}
    
    \tableofcontents 
    
    \chapter{Capybara}
    
    test
    
    \addchap{Wombat}
    
    \begin{theindex}
    \end{theindex}
    
    \end{document}

  3. #3
    Registrierter Benutzer
    Registriert seit
    31.07.2009
    Beiträge
    62
    So ist der Index leider leer.

    Wenn ich dann folgendes schreibe, dann steht zuerst Index da, dann zwei leere Seiten und danach steht wieder Index da und der Index wird gedruckt.

    Code:
    \documentclass[12pt,a4paper,index=totoc]{scrbook} 
    
    \usepackage[OT1]{eulervm}
    \usepackage{classicthesis}
    \usepackage{arsclassica} 
    
    \begin{document}
    
    \tableofcontents 
    
    \chapter{Test}
    
    test
    
    \addchap{Index}
    
    \printindex
    
    \end{document}
    Würde das ganze auch mit Tabellen- und Abbildungsverzeichnis verwenden.
    Wie geht das?

  4. #4
    Registrierter Benutzer
    Registriert seit
    20.07.2013
    Beiträge
    172
    listof=totoc

    Übrigens wäre es schön, wenn du mein Beispiel testen würdest.

  5. #5
    Registrierter Benutzer
    Registriert seit
    31.07.2009
    Beiträge
    62
    hab dein beispiel getestet und als rückmeldung geschrieben, dass dann der index leer war (siehe mein posting von 22:02).

    was bdeutet listof=totoc, kann damit nichts anfangen. wo muss ich das hinschreiben?

    wie muss der code nun also aussehen, dass die überschriften im inhaltsverzeichnis passen und dass der index nicht leer ist?
    wie kann ich dasselbe mit tabellen- und abbildungsverzeichnis machen?

  6. #6
    Registrierter Benutzer
    Registriert seit
    09.12.2005
    Beiträge
    1.284
    Zu scrbook gibt es eine Anleitung. In der kann man sowohl die Bedeutung von Optionen nachlesen, als auch wie man diese setzt. Desweiteren darf man ruhig auch einmal zwei Minuten nachdenken und dann die Ähnlichkeit mit index=totoc erkennen.

    Dass der Index ohne Indexeintrag leer bleibt, ist übrigens nicht verwunderlich. Deshalb aus dem Kapitel Wombat ein Kapitel Index zu machen, ist allerdings Unfug.

  7. #7
    Registrierter Benutzer
    Registriert seit
    31.07.2009
    Beiträge
    62
    habs mit folgendem code probiert, doch leider ist das abbildungsverzeichnis wieder mit einer anderen schrift im inhaltsverzeichnis, für index und literaturverzeichnis funktionierts.
    was muss ich ändern?

    Code:
    \documentclass[12pt,a4paper,index=totoc,bibliography=totoc,listof=totoc]{scrbook} 
    
    \usepackage[OT1]{eulervm}
    \usepackage{classicthesis}
    \usepackage{arsclassica} 
    %\usepackage{makeidx}
    
    \begin{document}
    
    \tableofcontents 
    
    \chapter{Capybara}
    
    test\index{test} test \index{test2}
    
    \begin{figure}
    \caption{Test-Figure}
    \end{figure}
    
    \addchap{Wombat}
    
    \listoffigures
    
    \begin{theindex}
    \end{theindex} 
    
    \end{document}
    Geändert von Oelle74 (18-01-2017 um 07:48 Uhr)

  8. #8
    Registrierter Benutzer
    Registriert seit
    09.12.2005
    Beiträge
    1.284
    classicthesis kann ganz schlecht mit KOMA-Script-Klassen umgehen. Deshalb gibt es u. a. auch Warnungen der Art:
    Code:
    Class scrbook Warning: Usage of package `titlesec' together
    (scrbook)              with a KOMA-Script class is not recommended.
    (scrbook)              I'd suggest to use the package only
    (scrbook)              if you really need it, because it breaks several
    (scrbook)              KOMA-Script features, i.e., option `headings' and
    (scrbook)              the extended optional argument of the section
    (scrbook)              commands.
    (scrbook)              Nevertheless, using requested
    (scrbook)              package `titlesec' on input line 378.
    
    (/usr/local/texlive/2016/texmf-dist/tex/latex/titlesec/titlesec.sty
    
    Package titlesec Warning: Non standard sectioning command detected
    (titlesec)                Using default spacing and no format.
    arsclassica basiert übrigens auf classicthesis und lädt das Paket selbst.

    Verzeichniseinträge nicht nummerierter Kapitel sind hier offenbar eines der erwähnten Probleme. Das \spacedlowersmallcaps, das classicthesis auf irgend eine Art bei anderen Einträgen hineinschmuggelt, fügt es in diesem Fall nicht ein.
    Geändert von klops (18-01-2017 um 15:34 Uhr)

  9. #9
    Registrierter Benutzer
    Registriert seit
    31.07.2009
    Beiträge
    62
    Gibts da keine Möglichkeit?

  10. #10
    Registrierter Benutzer
    Registriert seit
    09.12.2005
    Beiträge
    1.284
    Den Autor von classicthesis bitten, es kompatibel mit KOMA-Script zu machen, oder auf den Komfort von KOMA-Script bezüglich der …=totoc-Optionen verzichten.

  11. #11
    Registrierter Benutzer
    Registriert seit
    20.07.2013
    Beiträge
    172

  12. #12
    Registrierter Benutzer
    Registriert seit
    31.07.2009
    Beiträge
    62
    habs gelöst

    Code:
    \documentclass[12pt,a4paper,index=totoc]{scrbook} 
    
    \usepackage[OT1]{eulervm}
    \usepackage{classicthesis}
    \usepackage{arsclassica} 
    %\usepackage{makeidx}
    
    \begin{document}
    
    \tableofcontents 
    
    \chapter{Capybara}
    
    test\index{test} test \index{test2}
    
    \begin{figure}
    \caption{Test-Figure}
    \end{figure}
    
    \addchap{Wombat}
    
    \addcontentsline{toc}{chapter}{\tocEntry{Tabellenverzeichnis}}
    \listoffigures
    
    \begin{theindex}
    \end{theindex} 
    
    \end{document}

  13. #13
    Registrierter Benutzer Avatar von rais
    Registriert seit
    18.07.2005
    Beiträge
    5.662
    Zitat Zitat von Oelle74 Beitrag anzeigen
    habs gelöst
    öhhm, das Schriftproblem vllt, aber so setzt Du Deinen Verweis aufs Abbildungsverzeichnis (den Du hier auch noch Tabellenverzeichnis nennst) auf die falsche Seite (und gehört eigentlich zu `Wombat').
    Code:
    \cleardoublepage
    \addcontentsline{toc}{chapter}{\tocEntry{\listfigurename}}
    \listoffigures
    sollte passen.

    VG
    Rainer
    There's nothing a good whack with a hammer won't fix!

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •