PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Leere Seiten nach chapter unterdrücken


unex
16-09-2005, 00:50
Ich habe das Problem das er mir automatisch nach der titelseite, der inhaltsangabe, jedem part und jedem chapter eine leere Seite einfügt.

Kann mir jemand sagen wie ich das änder?
Optionen [a4wide][a4paper] sind aktiviert.
documentclass{book}

Danke schonmal!

knu
16-09-2005, 06:35
Hallo.

Ich habe das Problem das er mir automatisch nach der titelseite, der inhaltsangabe, jedem part und jedem chapter eine leere Seite einfügt.

Wer ist "er"? - Der LaTeX???

Nun gut: Das liegt wahrsch. daran, dass die Dokumentklasse book jedes Kapitel auf einer ungeraden Seite anfängen lässt - wie in einem Buch mit Kapiteln üblich. Wenn die genannten Dinge dummerweise immer auf eine gerade Seite Fallen, dann wird halt eine Seite freigelassen. Ich denke, so in etwa war das ...

Knu

Achja, hätte ich doch fast die Lsg. vergessen: openany als Klassenoption dürfte Dir weiterhelfen.

unex
16-09-2005, 12:35
Er = der Compiler = der Computer... was auch immer :)

Danke für den Tipp, funktioniert soweit auch ganz gut, nur bei manchen Kapiteln mach er immer noch eine leere Seite, allerdings nur in der 2ten datei die ich mit input{} include, hier scheint er die Kapitel immernoch nur auf der rechten Seite beginnen zu lassen.

knu
16-09-2005, 12:40
Du könntest ja mal ein Minimalbeispiel schicken. Dann könnte ich das nachvollziehen.

unex
16-09-2005, 13:39
So sieht meine basisdatei aus, in der ich dann die einzelnen Parts mit input{} include


\documentclass[openany,a4paper]{book}
\usepackage{german}
\usepackage{a4wide}

\usepackage{epsfig}
\usepackage{graphicx}
%\DeclareGraphicsRule{*}{mps}{*}{}

\usepackage{amsmath}
\usepackage{amscd}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{amsthm}
\usepackage[latin1]{inputenc}

\begin{document}
\title{Projekttitel}
\author{Autorname}
\date{\today}

\maketitle

\tableofcontents

\input{include1}
\input{include2}

\end{document}


so sieht eine der includeten dateien aus, wobei es bei der include1 geht und bei include2 mach er dann wieder leere Seiten um die Kapitel auf der rechten seite beginnen zu lassen.

\part{Teil1}
\chapter{Kapitel1}
\section{test}
\subsection{test1}
\subsection{test2}
\subsection{test3}
\chapter{Kapitel2}
\section{test2}
\subsection{test4}
\subsection{test5}
\subsection{test6}

knu
16-09-2005, 13:52
Also das, was Du mir da geschickt hast funktioniert bei mir wunderbar - ich kann dein Problem nicht nachvollziehen. Habe jetzt zweimal hintereinander deine Beispiel-Inputdatei eingefügt und sie werden alle hintereinander ohne leere Seiten erstellt.

unex
16-09-2005, 13:58
k danke für deine Hilfe ich werde es schon noch irgendwie hinbekommen, der Fehler muss jetzt ja eindeutig bei mir liegen.. werde wohl irgendwas verpeilt haben.

Danke.

*samantha*
23-10-2005, 20:08
Was bei mir geholfen hat - leider ja nun aber auch nicht Sinn und Zweck der book-klasse ist:

Die Option oneside hinzufügen - dann beginnen die Chapters jeweils auf beiden Seiten, je nachdem, wohin der Anfang eben fällt:

\documentclass[a4paper,12pt,oneside]{scrbook}

Das umgeht das Problem zwar, statt es elegant zu lösen, aber diese Lösung ist besser als keine, denke ich.

Grüße
Sam